{"answers":{"affected":"4 open source packages ship an affected version, including russh. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28113 in the wild and no public exploit code.","fix":"Upgrade russh to a fixed version for your release line: 0.36.2 or 0.37.1.","what":"CVE-2023-28113 is a medium-severity vulnerability in warp-tech russh, published on 16 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-28113 and fix it if it is affected.\n\nWhat it is: CVE-2023-28113 is a medium-severity vulnerability in warp-tech russh, published on 16 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-28113 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- russh (crates.io): affected all versions; fixed in 0.36.2\n- russh (crates.io): affected all versions; fixed in 0.36.2\n- russh (crates.io): affected from 0.37.0; fixed in 0.37.1\n- russh (crates.io): affected from 0.37.0; fixed in 0.37.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28113/ (Markdown: https://insights.sbomify.com/CVE-2023-28113/index.md)","id":"CVE-2023-28113","markdown":"https://insights.sbomify.com/CVE-2023-28113/index.md","name":"CVE-2023-28113","record":{"aliases":["GHSA-cqvm-j2r2-hwpg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust SSH library","requires_auth":"none","summary":"Insufficient Diffie-Hellman key validation in russh allows eavesdropping on SSH connections, compromising confidentiality.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"russh","vendor":"russh_project"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"},{"id":"CWE-358","name":"Improperly Implemented Security Check for Standard"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"russh is a Rust SSH client and server library. Starting in version 0.34.0 and prior to versions 0.36.2 and 0.37.1, Diffie-Hellman key validation is insufficient, which can lead to insecure shared secrets and therefore breaks confidentiality. Connections between a russh client and server or those of a russh peer with some other misbehaving peer are most likely to be problematic. These may vulnerable to eavesdropping. Most other implementations reject such keys, so this is mainly an interoperability issue in such a case. This issue is fixed in versions 0.36.2 and 0.37.1","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"russh may use insecure Diffie-Hellman keys","id":"CVE-2023-28113","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"weak_cryptography","year":"2023"},"n_packages":4,"n_references":6,"next":{"headline":"`cilium-cli` disables etcd authorization for clustermesh clusters","id":"CVE-2023-28114"},"packages":[{"ecosystem":"crates.io","fixed":["0.36.2"],"introduced":["0"],"last_affected":[],"package":"russh","purl":null,"source":"GHSA-cqvm-j2r2-hwpg"},{"ecosystem":"crates.io","fixed":["0.36.2"],"introduced":["0"],"last_affected":[],"package":"russh","purl":"pkg:cargo/russh","source":"GHSA-cqvm-j2r2-hwpg"},{"ecosystem":"crates.io","fixed":["0.37.1"],"introduced":["0.37.0"],"last_affected":[],"package":"russh","purl":null,"source":"GHSA-cqvm-j2r2-hwpg"},{"ecosystem":"crates.io","fixed":["0.37.1"],"introduced":["0.37.0"],"last_affected":[],"package":"russh","purl":"pkg:cargo/russh","source":"GHSA-cqvm-j2r2-hwpg"}],"prev":{"headline":"Discourse's SSRF protection missing for some FastImage requests","id":"CVE-2023-28112"},"products":["russh"],"published":"2023-03-16","related":[{"cvss_score":7.5,"headline":"Russh: Pre-auth DoS via unbounded allocation in keyboard-interactive auth","id":"CVE-2026-42189","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":7.5,"headline":"Russh has an OOM Denial of Service due to allocation of untrusted amount","id":"CVE-2024-43410","kev_date_added":null,"published":"2024-08-21"},{"cvss_score":6.5,"headline":"Russh is missing an overflow check during channel windows adjust","id":"CVE-2025-54804","kev_date_added":null,"published":"2025-08-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["warp-tech"]},"summary":"Insufficient Diffie-Hellman key validation in russh allows eavesdropping on SSH connections, compromising confidentiality.","url":"https://insights.sbomify.com/CVE-2023-28113/"}