# CVE-2023-28113: russh may use insecure Diffie-Hellman keys

> Insufficient Diffie-Hellman key validation in russh allows eavesdropping on SSH connections, compromising confidentiality.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-cqvm-j2r2-hwpg

## What is CVE-2023-28113?

CVE-2023-28113 is a medium-severity vulnerability in warp-tech russh, published on 16 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

russh is a Rust SSH client and server library. Starting in version 0.34.0 and prior to versions 0.36.2 and 0.37.1, Diffie-Hellman key validation is insufficient, which can lead to insecure shared secrets and therefore breaks confidentiality. Connections between a russh client and server or those of a russh peer with some other misbehaving peer are most likely to be problematic. These may vulnerable to eavesdropping. Most other implementations reject such keys, so this is mainly an interoperability issue in such a case. This issue is fixed in versions 0.36.2 and 0.37.1

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-358 (Improperly Implemented Security Check for Standard), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-28113?

4 open source packages ship an affected version, including russh. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `russh` | crates.io | All versions | 0.36.2 |
| `russh` | crates.io | All versions | 0.36.2 |
| `russh` | crates.io | From 0.37.0 | 0.37.1 |
| `russh` | crates.io | From 0.37.0 | 0.37.1 |

Products: Russh Project Russh.

## How do I fix CVE-2023-28113?

Upgrade russh to a fixed version for your release line: 0.36.2 or 0.37.1.

## Is CVE-2023-28113 being exploited?

There is no known exploitation of CVE-2023-28113 in the wild and no public exploit code.

## Other vulnerabilities in warp-tech russh

- [CVE-2026-42189](https://insights.sbomify.com/CVE-2026-42189/): Russh: Pre-auth DoS via unbounded allocation in keyboard-interactive auth (high 7.5)
- [CVE-2024-43410](https://insights.sbomify.com/CVE-2024-43410/): Russh has an OOM Denial of Service due to allocation of untrusted amount (high 7.5)
- [CVE-2025-54804](https://insights.sbomify.com/CVE-2025-54804/): Russh is missing an overflow check during channel windows adjust (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28113 and fix it if it is affected.

What it is: CVE-2023-28113 is a medium-severity vulnerability in warp-tech russh, published on 16 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28113 in the wild and no public exploit code.

Affected packages and fixed versions:
- russh (crates.io): affected all versions; fixed in 0.36.2
- russh (crates.io): affected all versions; fixed in 0.36.2
- russh (crates.io): affected from 0.37.0; fixed in 0.37.1
- russh (crates.io): affected from 0.37.0; fixed in 0.37.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28113/ (Markdown: https://insights.sbomify.com/CVE-2023-28113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28113
- OSV: https://osv.dev/vulnerability/CVE-2023-28113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28113/
Summaries are generated and may contain mistakes; the official description above is the record.
