# CVE-2023-28114: `cilium-cli` disables etcd authorization for clustermesh clusters

> Attacker with valid etcd credentials can modify cluster state because cilium-cli incorrectly disables etcd authorization during cluster mesh setup.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-6f27-3p6c-p5jc, GO-2023-1653

## What is CVE-2023-28114?

CVE-2023-28114 is a medium-severity missing authorization vulnerability in cilium-cli, published on 22 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

`cilium-cli` is the command line interface to install, manage, and troubleshoot Kubernetes clusters running Cilium. Prior to version 0.13.2,`cilium-cli`, when used to configure cluster mesh functionality, can remove the enforcement of user permissions on the `etcd` store used to mirror local cluster information to remote clusters. Users who have set up cluster meshes using the Cilium Helm chart are not affected by this issue.

Due to an incorrect mount point specification, the settings specified by the `initContainer` that configures `etcd` users and their permissions are overwritten when using `cilium-cli` to configure a cluster mesh. An attacker who has already gained access to a valid key and certificate for an `etcd` cluster compromised in this manner could then modify state in that `etcd` cluster.

This issue is patched in `cilium-cli` 0.13.2. As a workaround, one may use Cilium's Helm charts to create their cluster.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions), CWE-280 (Improper Handling of Insufficient Permissions or Privileges)

## Which versions are affected by CVE-2023-28114?

3 open source packages ship an affected version, including github.com/cilium/cilium-cli. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium-cli` | Go | All versions | 0.13.2 |
| `github.com/cilium/cilium-cli` | Go | All versions | 0.13.2 |
| `github.com/cilium/cilium-cli` | Go | All versions | 0.13.2 |

Products: Cilium Cilium-Cli.

## How do I fix CVE-2023-28114?

Upgrade github.com/cilium/cilium-cli to 0.13.2 or later.

## Is CVE-2023-28114 being exploited?

There is no known exploitation of CVE-2023-28114 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28114 and fix it if it is affected.

What it is: CVE-2023-28114 is a medium-severity missing authorization vulnerability in cilium-cli, published on 22 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28114 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium-cli (Go): affected all versions; fixed in 0.13.2
- github.com/cilium/cilium-cli (Go): affected all versions; fixed in 0.13.2
- github.com/cilium/cilium-cli (Go): affected all versions; fixed in 0.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28114/ (Markdown: https://insights.sbomify.com/CVE-2023-28114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28114
- OSV: https://osv.dev/vulnerability/CVE-2023-28114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28114/
Summaries are generated and may contain mistakes; the official description above is the record.
