# CVE-2023-28115: Snappy vulnerable to PHAR deserialization, allowing remote code execution

> Attackers can achieve remote code execution via PHAR deserialization in the Snappy PHP library if they can upload files and trigger specific functions.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** DEBIAN-CVE-2023-28115, GHSA-gq6w-q6wh-jggc, UBUNTU-CVE-2023-28115

## What is CVE-2023-28115?

CVE-2023-28115 is a critical unsafe deserialization vulnerability in KnpLabs snappy, published on 17 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Snappy is a PHP library allowing thumbnail, snapshot or PDF generation from a url or a html page. Prior to version 1.4.2, Snappy is vulnerable to PHAR deserialization due to a lack of checking on the protocol before passing it into the `file_exists()` function. If an attacker can upload files of any type to the server he can pass in the phar:// protocol to unserialize the uploaded file and instantiate arbitrary PHP objects. This can lead to remote code execution especially when snappy is used with frameworks with documented POP chains like Laravel/Symfony vulnerable developer code. If a user can control the output file from the `generateFromHtml()` function, it will invoke deserialization. This vulnerability is capable of remote code execution if Snappy is used with frameworks or developer code with vulnerable POP chains. It has been fixed in version 1.4.2.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-28115?

2 open source packages ship an affected version, including knplabs/knp-snappy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `knplabs/knp-snappy` | Packagist | All versions | 1.4.2 |
| `knplabs/knp-snappy` | Packagist | All versions | 1.4.2 |

Products: Knplabs Snappy.

## How do I fix CVE-2023-28115?

Upgrade knplabs/knp-snappy to 1.4.2 or later.

## Is CVE-2023-28115 being exploited?

There is no known exploitation of CVE-2023-28115 in the wild and no public exploit code.

## Other vulnerabilities in KnpLabs snappy

- [CVE-2023-41330](https://insights.sbomify.com/CVE-2023-41330/): Unsafe deserialization in knplabs/knp-snappy (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28115 and fix it if it is affected.

What it is: CVE-2023-28115 is a critical unsafe deserialization vulnerability in KnpLabs snappy, published on 17 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28115 in the wild and no public exploit code.

Affected packages and fixed versions:
- knplabs/knp-snappy (Packagist): affected all versions; fixed in 1.4.2
- knplabs/knp-snappy (Packagist): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28115/ (Markdown: https://insights.sbomify.com/CVE-2023-28115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28115
- OSV: https://osv.dev/vulnerability/CVE-2023-28115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28115/
Summaries are generated and may contain mistakes; the official description above is the record.
