# CVE-2023-28117: Sentry SDK leaks sensitive session information when `sendDefaultPII` is set to `True`

> Sentry Python SDK leaks sensitive session cookies to Sentry when sendDefaultPII is enabled with custom cookie names, allowing potential account takeover.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-29pr-6jr8-q5jm, PYSEC-2026-920, ROOT-APP-PYPI-CVE-2023-28117, UBUNTU-CVE-2023-28117

## What is CVE-2023-28117?

CVE-2023-28117 is a high-severity vulnerability in getsentry sentry-python, published on 22 Mar 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Sentry SDK is the official Python SDK for Sentry, real-time crash reporting software. When using the Django integration of versions prior to 1.14.0 of the Sentry SDK in a specific configuration it is possible to leak sensitive cookies values, including the session cookie to Sentry. These sensitive cookies could then be used by someone with access to your Sentry issues to impersonate or escalate their privileges within your application.

In order for these sensitive values to be leaked, the Sentry SDK configuration must have `sendDefaultPII` set to `True`; one must use a custom name for either `SESSION_COOKIE_NAME` or `CSRF_COOKIE_NAME` in one's Django settings; and one must not be configured in one's organization or project settings to use Sentry's data scrubbing features to account for the custom cookie names.

As of version 1.14.0, the Django integration of the `sentry-sdk` will detect the custom cookie names based on one's Django settings and will remove the values from the payload before sending the data to Sentry. As a workaround, use the SDK's filtering mechanism to remove the cookies from the payload that is sent to Sentry. For error events, this can be done with the `before_send` callback method and for performance related events (transactions) one can use the `before_send_transaction` callback method. Those who want to handle filtering of these values on the server-side can also use Sentry's advanced data scrubbing feature to account for the custom cookie names. Look for the `$http.cookies`, `$http.headers`, `$request.cookies`, or `$request.headers` fields to target with a scrubbing rule.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information), CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2023-28117?

3 open source packages ship an affected version, including sentry-sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sentry-sdk` | PyPI | All versions | 1.14.0 |
| `sentry-sdk` | PyPI | All versions | 1.14.0 |
| `sentry-sdk` | PyPI | All versions | 1.14.0 |

Products: Sentry Sentry Software Development Kit.

## How do I fix CVE-2023-28117?

Upgrade sentry-sdk to 1.14.0 or later.

## Is CVE-2023-28117 being exploited?

There is no known exploitation of CVE-2023-28117 in the wild and no public exploit code.

## Other vulnerabilities in getsentry sentry-python

- [CVE-2023-46729](https://insights.sbomify.com/CVE-2023-46729/): Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28117 and fix it if it is affected.

What it is: CVE-2023-28117 is a high-severity vulnerability in getsentry sentry-python, published on 22 Mar 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28117 in the wild and no public exploit code.

Affected packages and fixed versions:
- sentry-sdk (PyPI): affected all versions; fixed in 1.14.0
- sentry-sdk (PyPI): affected all versions; fixed in 1.14.0
- sentry-sdk (PyPI): affected all versions; fixed in 1.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28117/ (Markdown: https://insights.sbomify.com/CVE-2023-28117/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28117
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28117
- OSV: https://osv.dev/vulnerability/CVE-2023-28117

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28117/
Summaries are generated and may contain mistakes; the official description above is the record.
