{"answers":{"affected":"2 open source packages ship an affected version, including com.charleskorn.kaml:kaml. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28118 in the wild and no public exploit code.","fix":"Upgrade com.charleskorn.kaml:kaml to 0.53.0 or later.","what":"CVE-2023-28118 is a high-severity denial of service vulnerability in charleskorn kaml, published on 20 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-28118 and fix it if it is affected.\n\nWhat it is: CVE-2023-28118 is a high-severity denial of service vulnerability in charleskorn kaml, published on 20 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-28118 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.charleskorn.kaml:kaml (Maven): affected all versions; fixed in 0.53.0\n- com.charleskorn.kaml:kaml (Maven): affected all versions; fixed in 0.53.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28118/ (Markdown: https://insights.sbomify.com/CVE-2023-28118/index.md)","id":"CVE-2023-28118","markdown":"https://insights.sbomify.com/CVE-2023-28118/index.md","name":"CVE-2023-28118","record":{"aliases":["GHSA-c24f-2j3g-rg48"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Kotlin YAML library","requires_auth":"none","summary":"Attackers can cause excessive memory consumption and crashes in applications using kaml to parse untrusted YAML input with anchors and aliases.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"kaml","vendor":"kaml_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-776","name":"Improper Restriction of Recursive Entity References in DTDs"}],"description":"kaml provides YAML support for kotlinx.serialization. Prior to version 0.53.0, applications that use kaml to parse untrusted input containing anchors and aliases may consume excessive memory and crash. Version 0.53.0 and later default to refusing to parse YAML documents containing anchors and aliases. There are no known workarounds.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"kaml has potential denial of service while parsing input with anchors and aliases","id":"CVE-2023-28118","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"crewjam/saml vulnerable to Denial Of Service Via Deflate Decompression Bomb","id":"CVE-2023-28119"},"packages":[{"ecosystem":"Maven","fixed":["0.53.0"],"introduced":["0"],"last_affected":[],"package":"com.charleskorn.kaml:kaml","purl":null,"source":"GHSA-c24f-2j3g-rg48"},{"ecosystem":"Maven","fixed":["0.53.0"],"introduced":["0"],"last_affected":[],"package":"com.charleskorn.kaml:kaml","purl":"pkg:maven/com.charleskorn.kaml/kaml","source":"GHSA-c24f-2j3g-rg48"}],"prev":{"headline":"Sentry SDK leaks sensitive session information when `sendDefaultPII` is set to `True`","id":"CVE-2023-28117"},"products":["kaml"],"published":"2023-03-20","related":[{"cvss_score":4.3,"headline":"Denial of service while parsing polymorphic input with tagged polymorphism style in kaml","id":"CVE-2021-39194","kev_date_added":null,"published":"2021-09-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["charleskorn"]},"summary":"Attackers can cause excessive memory consumption and crashes in applications using kaml to parse untrusted YAML input with anchors and aliases.","url":"https://insights.sbomify.com/CVE-2023-28118/"}