# CVE-2023-28118: kaml has potential denial of service while parsing input with anchors and aliases

> Attackers can cause excessive memory consumption and crashes in applications using kaml to parse untrusted YAML input with anchors and aliases.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-c24f-2j3g-rg48

## What is CVE-2023-28118?

CVE-2023-28118 is a high-severity denial of service vulnerability in charleskorn kaml, published on 20 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

kaml provides YAML support for kotlinx.serialization. Prior to version 0.53.0, applications that use kaml to parse untrusted input containing anchors and aliases may consume excessive memory and crash. Version 0.53.0 and later default to refusing to parse YAML documents containing anchors and aliases. There are no known workarounds.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2023-28118?

2 open source packages ship an affected version, including com.charleskorn.kaml:kaml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.charleskorn.kaml:kaml` | Maven | All versions | 0.53.0 |
| `com.charleskorn.kaml:kaml` | Maven | All versions | 0.53.0 |

Products: Kaml Project Kaml.

## How do I fix CVE-2023-28118?

Upgrade com.charleskorn.kaml:kaml to 0.53.0 or later.

## Is CVE-2023-28118 being exploited?

There is no known exploitation of CVE-2023-28118 in the wild and no public exploit code.

## Other vulnerabilities in charleskorn kaml

- [CVE-2021-39194](https://insights.sbomify.com/CVE-2021-39194/): Denial of service while parsing polymorphic input with tagged polymorphism style in kaml (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28118 and fix it if it is affected.

What it is: CVE-2023-28118 is a high-severity denial of service vulnerability in charleskorn kaml, published on 20 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28118 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.charleskorn.kaml:kaml (Maven): affected all versions; fixed in 0.53.0
- com.charleskorn.kaml:kaml (Maven): affected all versions; fixed in 0.53.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28118/ (Markdown: https://insights.sbomify.com/CVE-2023-28118/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28118
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28118
- OSV: https://osv.dev/vulnerability/CVE-2023-28118

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28118/
Summaries are generated and may contain mistakes; the official description above is the record.
