# CVE-2023-28131: Expo SDK has an OAuth vulnerability

> Attackers can steal credentials and take over accounts via malicious links in apps using Expo AuthSession Redirect Proxy for social sign-in.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Apr 2023
- **Updated:** 4 Feb 2025
- **Also known as:** GHSA-wr5g-q49g-548w

## What is CVE-2023-28131?

CVE-2023-28131 is a critical vulnerability in Expo.io Expo AuthSession module, published on 24 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability in the expo.io framework allows an attacker to take over accounts and steal credentials on an application/website that configured the "Expo AuthSession Redirect Proxy" for social sign-in. This can be achieved once a victim clicks a malicious link. The link itself may be sent to the victim in various ways (including email, text message, an attacker-controlled website, etc).

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2023-28131?

2 open source packages ship an affected version, including expo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `expo` | npm | All versions | 48.0.0 |
| `expo` | npm | All versions | 48.0.0 |

Products: Expo Expo Software Development Kit.

## How do I fix CVE-2023-28131?

Upgrade expo to 48.0.0 or later.

## Is CVE-2023-28131 being exploited?

There is no known exploitation of CVE-2023-28131 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28131 and fix it if it is affected.

What it is: CVE-2023-28131 is a critical vulnerability in Expo.io Expo AuthSession module, published on 24 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-28131 in the wild and no public exploit code.

Affected packages and fixed versions:
- expo (npm): affected all versions; fixed in 48.0.0
- expo (npm): affected all versions; fixed in 48.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28131/ (Markdown: https://insights.sbomify.com/CVE-2023-28131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28131
- OSV: https://osv.dev/vulnerability/CVE-2023-28131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28131/
Summaries are generated and may contain mistakes; the official description above is the record.
