{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28144 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2023-28144 is a high-severity vulnerability in n/a, published on 14 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-28144 and fix it if it is affected.\n\nWhat it is: CVE-2023-28144 is a high-severity vulnerability in n/a, published on 14 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28144 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28144/ (Markdown: https://insights.sbomify.com/CVE-2023-28144/index.md)","id":"CVE-2023-28144","markdown":"https://insights.sbomify.com/CVE-2023-28144/index.md","name":"CVE-2023-28144","record":{"aliases":["DEBIAN-CVE-2023-28144","GHSA-r4wr-r3pf-8cvw","UBUNTU-CVE-2023-28144","openSUSE-SU-2024:12782-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"KDAB Hotspot profiler","requires_auth":"low_privilege","summary":"Attackers can escalate privileges via race conditions in symlink handling when using a non-default configuration in KDAB Hotspot.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"hotspot","vendor":"kdab"}],"cvss":{"score":7,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"KDAB Hotspot 1.3.x and 1.4.x through 1.4.1, in a non-default configuration, allows privilege escalation because of race conditions involving symlinks and elevate_perf_privileges.sh chown calls.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Race condition in n/a","id":"CVE-2023-28144","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"race_condition","year":"2023"},"n_packages":1,"n_references":2,"next":{"headline":"Use after free in n/a","id":"CVE-2023-28147"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.4.1-1.1"],"introduced":["0"],"last_affected":[],"package":"hotspot","purl":"pkg:rpm/opensuse/hotspot\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12782-1"}],"prev":{"headline":"Local Privilege Escalation","id":"CVE-2023-28143"},"products":["n/a"],"published":"2023-03-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-27","vendors":["n/a"]},"summary":"Attackers can escalate privileges via race conditions in symlink handling when using a non-default configuration in KDAB Hotspot.","url":"https://insights.sbomify.com/CVE-2023-28144/"}