{"answers":{"affected":"4 open source packages ship an affected version, including @cypress/request and request. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28155 in the wild and no public exploit code.","fix":"Upgrade @cypress/request to 3.0.0 or later.","what":"CVE-2023-28155 is a medium-severity server-side request forgery vulnerability in n/a, published on 16 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-28155 and fix it if it is affected.\n\nWhat it is: CVE-2023-28155 is a medium-severity server-side request forgery vulnerability in n/a, published on 16 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-28155 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @cypress/request (npm): affected all versions; fixed in 3.0.0\n- @cypress/request (npm): affected all versions; fixed in 3.0.0\n- request (npm): affected all versions up to 2.88.2; no fix listed\n- request (npm): affected all versions up to 2.88.2; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28155/ (Markdown: https://insights.sbomify.com/CVE-2023-28155/index.md)","id":"CVE-2023-28155","markdown":"https://insights.sbomify.com/CVE-2023-28155/index.md","name":"CVE-2023-28155","record":{"aliases":["AZL-25664","AZL-43444","AZL-44241","CLSA-2026-1773965914","CLSA-2026-1775003197","CLSA-2026-1775003222","CLSA-2026-1776991061","CLSA-2026-1776991070","CLSA-2026-1788862348","CLSA-2026-1793208346","DEBIAN-CVE-2023-28155","GHSA-p8p7-x288-28g6","MINI-h8rg-7v5f-hcfm","MINI-j668-rpwg-48r9","ROOT-APP-NPM-CVE-2023-28155","UBUNTU-CVE-2023-28155"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP client","requires_auth":"none","summary":"An attacker can bypass SSRF protections in the Node.js Request package by using cross-protocol redirects, affecting unsupported software.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"request","vendor":"request_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"The Request package through 2.88.1 for Node.js allows a bypass of SSRF mitigations via an attacker-controller server that does a cross-protocol redirect (HTTP to HTTPS, or HTTPS to HTTP). NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Server-Side Request Forgery in Request","id":"CVE-2023-28155","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2023"},"n_packages":4,"n_references":4,"next":{"headline":"Apache Archiva privilege escalation","id":"CVE-2023-28158"},"packages":[{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"@cypress/request","purl":null,"source":"GHSA-p8p7-x288-28g6"},{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"@cypress/request","purl":"pkg:npm/%40cypress/request","source":"GHSA-p8p7-x288-28g6"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["2.88.2"],"package":"request","purl":null,"source":"GHSA-p8p7-x288-28g6"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["2.88.2"],"package":"request","purl":"pkg:npm/request","source":"GHSA-p8p7-x288-28g6"}],"prev":{"headline":"Cross-realm object access in Webpack 5","id":"CVE-2023-28154"},"products":["n/a"],"published":"2023-03-16","related":[{"cvss_score":5.9,"headline":"Remote Memory Exposure in request","id":"CVE-2017-16026","kev_date_added":null,"published":"2018-06-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"An attacker can bypass SSRF protections in the Node.js Request package by using cross-protocol redirects, affecting unsupported software.","url":"https://insights.sbomify.com/CVE-2023-28155/"}