# CVE-2023-28155: Server-Side Request Forgery in Request

> An attacker can bypass SSRF protections in the Node.js Request package by using cross-protocol redirects, affecting unsupported software.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Mar 2023
- **Updated:** 2 Aug 2024
- **Also known as:** AZL-25664, AZL-43444, AZL-44241, CLSA-2026-1773965914, CLSA-2026-1775003197, CLSA-2026-1775003222, CLSA-2026-1776991061, CLSA-2026-1776991070, CLSA-2026-1788862348, CLSA-2026-1793208346, DEBIAN-CVE-2023-28155, GHSA-p8p7-x288-28g6, MINI-h8rg-7v5f-hcfm, MINI-j668-rpwg-48r9, ROOT-APP-NPM-CVE-2023-28155, UBUNTU-CVE-2023-28155

## What is CVE-2023-28155?

CVE-2023-28155 is a medium-severity server-side request forgery vulnerability in n/a, published on 16 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Request package through 2.88.1 for Node.js allows a bypass of SSRF mitigations via an attacker-controller server that does a cross-protocol redirect (HTTP to HTTPS, or HTTPS to HTTP). NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-28155?

4 open source packages ship an affected version, including @cypress/request and request. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@cypress/request` | npm | All versions | 3.0.0 |
| `@cypress/request` | npm | All versions | 3.0.0 |
| `request` | npm | All versions to 2.88.2 | None |
| `request` | npm | All versions to 2.88.2 | None |

Products: Request Project Request.

## How do I fix CVE-2023-28155?

Upgrade @cypress/request to 3.0.0 or later.

## Is CVE-2023-28155 being exploited?

There is no known exploitation of CVE-2023-28155 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-16026](https://insights.sbomify.com/CVE-2017-16026/): Remote Memory Exposure in request (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28155 and fix it if it is affected.

What it is: CVE-2023-28155 is a medium-severity server-side request forgery vulnerability in n/a, published on 16 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-28155 in the wild and no public exploit code.

Affected packages and fixed versions:
- @cypress/request (npm): affected all versions; fixed in 3.0.0
- @cypress/request (npm): affected all versions; fixed in 3.0.0
- request (npm): affected all versions up to 2.88.2; no fix listed
- request (npm): affected all versions up to 2.88.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28155/ (Markdown: https://insights.sbomify.com/CVE-2023-28155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28155
- OSV: https://osv.dev/vulnerability/CVE-2023-28155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28155/
Summaries are generated and may contain mistakes; the official description above is the record.
