# CVE-2023-2816: Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner

> Users with service write permissions can modify remote proxy configurations for services they do not own, bypassing intended access controls.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2023
- **Updated:** 7 Oct 2024
- **Also known as:** AZL-27396, AZL-35303, BIT-consul-2023-2816, GHSA-rqjq-ww83-wv5c, GO-2023-1828, UBUNTU-CVE-2023-2816

## What is CVE-2023-2816?

CVE-2023-2816 is a high-severity missing authorization vulnerability in HashiCorp Consul, published on 2 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Consul and Consul Enterprise allowed any user with service:write permissions to use Envoy extensions configured via service-defaults to patch remote proxy instances that target the configured service, regardless of whether the user has permission to modify the service(s) corresponding to those modified proxies.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2023-2816?

4 open source packages ship an affected version, including github.com/hashicorp/consul and consul. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/consul` | Go | From 1.15.0 | 1.15.3 |
| `github.com/hashicorp/consul` | Go | From 1.15.0 | 1.15.3 |
| `github.com/hashicorp/consul` | Go | From 1.15.0 | 1.15.3 |
| `consul` | Bitnami | From 1.15.0 | 1.15.3 |

Products: Hashicorp Consul.

## How do I fix CVE-2023-2816?

Upgrade github.com/hashicorp/consul to 1.15.3 or later.

## Is CVE-2023-2816 being exploited?

There is no known exploitation of CVE-2023-2816 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp Consul

- [CVE-2021-41805](https://insights.sbomify.com/CVE-2021-41805/): Privilege escalation in n/a (high 8.8)
- [CVE-2021-37219](https://insights.sbomify.com/CVE-2021-37219/): HashiCorp Consul Privilege Escalation Vulnerability (high 8.8)
- [CVE-2024-10006](https://insights.sbomify.com/CVE-2024-10006/): Consul L7 Intentions Vulnerable To Headers Bypass (high 8.3)
- [CVE-2024-10005](https://insights.sbomify.com/CVE-2024-10005/): Consul L7 Intentions Vulnerable To URL Path Bypass (high 8.1)
- [CVE-2019-8336](https://insights.sbomify.com/CVE-2019-8336/): HashiCorp Consul Access Restriction Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2816 and fix it if it is affected.

What it is: CVE-2023-2816 is a high-severity missing authorization vulnerability in HashiCorp Consul, published on 2 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-2816 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/consul (Go): affected from 1.15.0; fixed in 1.15.3
- github.com/hashicorp/consul (Go): affected from 1.15.0; fixed in 1.15.3
- github.com/hashicorp/consul (Go): affected from 1.15.0; fixed in 1.15.3
- consul (Bitnami): affected from 1.15.0; fixed in 1.15.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2816/ (Markdown: https://insights.sbomify.com/CVE-2023-2816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2816
- OSV: https://osv.dev/vulnerability/CVE-2023-2816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2816/
Summaries are generated and may contain mistakes; the official description above is the record.
