CVE-2023-2817 Stored cross site scripting in Craft CMS
Authenticated attackers can inject scripts into field names, leading to stored XSS when other users view categories or entries.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-2817?
CVE-2023-2817 is a medium-severity cross-site scripting vulnerability in Craftcms Craft Cms, published on 26 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A post-authentication stored cross-site scripting vulnerability exists in Craft CMS versions <= 4.4.11. HTML, including script tags can be injected into field names which, when the field is added to a category or section, will trigger when users visit the Categories or Entries pages respectively.
Weakness: CWE-79
Which versions are affected by CVE-2023-2817?
2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.4.12 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.4.12 |
Products include Craftcms Craft Cms.
How do I fix CVE-2023-2817?
Upgrade craftcms/cms to 4.4.12 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-2817 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2817 exists.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-7x94-jx75-3gh6.