# CVE-2023-2825: Path traversal in GitLab

> An unauthenticated attacker can read arbitrary server files via path traversal in GitLab when specific nested group attachment conditions are met.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2023
- **Updated:** 15 Jan 2025
- **Also known as:** BIT-gitlab-2023-2825, GHSA-x4jh-5c6x-h92v, UBUNTU-CVE-2023-2825

## What is CVE-2023-2825?

CVE-2023-2825 is a critical path traversal vulnerability in Gitlab Gitlab, published on 26 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue has been discovered in GitLab CE/EE affecting only version 16.0.0. An unauthenticated malicious user can use a path traversal vulnerability to read arbitrary files on the server when an attachment exists in a public project nested within at least five groups.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-2825?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 16.0.0 | 16.0.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2023-2825?

Upgrade gitlab to 16.0.1 or later.

## Is CVE-2023-2825 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2825 exists.

Public exploit code:

- GitLab CVE-2023-2825 PoC. This PoC leverages a path traversal vulnerability to retrieve the /etc/passwd file from a system running GitLab 16.0.0. (github_poc): https://github.com/Occamsec/CVE-2023-2825
- PoC for CVE-2023-2825: automated GitLab 16.0.0 arbitrary file read via nested public groups, project upload traversal, reusable upload paths, and clean CLI output. (github_poc): https://github.com/Groppoxx/CVE-2023-2825-PoC
- GitLab Authenticated File Read (metasploit)
- the proof of concept written in Python for an unauthenticated malicious user can use a path traversal vulnerability to read arbitrary files on the server when an attachment exists in a public project nested within at least five groups. This is a critical severity issue  (github_poc): https://github.com/Tornad0007/CVE-2023-2825-Gitlab
- On May 23, 2023 GitLab released version 16.0.1 which fixed a critical vulnerability, CVE-2023-2825, affecting the Community Edition (CE) and Enterprise Edition (EE) version 16.0.0. The vulnerability allows unauthenticated users to read arbitrary files through a path traversal bug. (github_poc): https://github.com/Rubikcuv5/CVE-2023-2825
- https://github.com/caopengyan/CVE-2023-2825 (github_poc): https://github.com/caopengyan/CVE-2023-2825

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2825 and fix it if it is affected.

What it is: CVE-2023-2825 is a critical path traversal vulnerability in Gitlab Gitlab, published on 26 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2825 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 16.0.0; fixed in 16.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2825/ (Markdown: https://insights.sbomify.com/CVE-2023-2825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2825
- OSV: https://osv.dev/vulnerability/CVE-2023-2825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2825/
Summaries are generated and may contain mistakes; the official description above is the record.
