CVE-2023-28330 Moodle: authenticated arbitrary file read through malformed backup file
Authenticated users with teacher or admin roles can read arbitrary files via a malformed backup file due to insufficient sanitization.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-28330?
CVE-2023-28330 is a medium-severity path traversal vulnerability in Moodle Moodle, published on 23 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Insufficient sanitizing in backup resulted in an arbitrary file read risk. The capability to access this feature is only available to teachers, managers and admins by default.
Weakness: CWE-20
Which versions are affected by CVE-2023-28330?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.9.20 |
moodle/moodle Packagist | All versions | 3.9.20 |
moodle/moodle Packagist | From 3.11.0 | 3.11.13 |
moodle/moodle Packagist | From 3.11.0 | 3.11.13 |
moodle/moodle Packagist | From 4.0.0 | 4.0.7 |
moodle/moodle Packagist | From 4.0.0 | 4.0.7 |
3 more packages
moodle/moodle Packagist | From 4.1.0 | 4.1.2 |
moodle/moodle Packagist | From 4.1.0 | 4.1.2 |
moodle Bitnami | From 3.9.0 | 3.9.20, 3.11.13, 4.0.7, 4.1.2 |
Products include Moodle Moodle.
How do I fix CVE-2023-28330?
Upgrade moodle/moodle to a fixed version for your release line: 3.9.20, 3.11.13, 4.0.7 or 4.1.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2023-28330 being exploited?
There is no known exploitation of CVE-2023-28330 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2023-28330, GHSA-56r9-72vx-q989, UBUNTU-CVE-2023-28330.