CVE-2023-28331 Moodle: xss risk when outputting database activity filter data
An attacker can inject malicious scripts via database activity filter data, potentially leading to session hijacking or code execution in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-28331?
CVE-2023-28331 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 23 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Content output by the database auto-linking filter required additional sanitizing to prevent an XSS risk.
Weakness: CWE-79
Which versions are affected by CVE-2023-28331?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.9.20 |
moodle/moodle Packagist | All versions | 3.9.20 |
moodle/moodle Packagist | From 3.11.0 | 3.11.13 |
moodle/moodle Packagist | From 3.11.0 | 3.11.13 |
moodle/moodle Packagist | From 4.0.0 | 4.0.7 |
moodle/moodle Packagist | From 4.0.0 | 4.0.7 |
3 more packages
moodle/moodle Packagist | From 4.1.0 | 4.1.2 |
moodle/moodle Packagist | From 4.1.0 | 4.1.2 |
moodle Bitnami | From 3.9.0 | 3.9.20, 3.11.13, 4.0.7, 4.1.2 |
Products include Moodle Moodle.
How do I fix CVE-2023-28331?
Upgrade moodle/moodle to a fixed version for your release line: 3.9.20, 3.11.13, 4.0.7 or 4.1.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-28331 being exploited?
There is no known exploitation of CVE-2023-28331 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2023-28331, GHSA-77jm-f3vj-xvx2, UBUNTU-CVE-2023-28331.