# CVE-2023-28425: Specially crafted MSETNX command can lead to denial-of-service

> Authenticated users can crash the Redis server by sending a specially crafted MSETNX command, causing a denial of service.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** AZL-25674, BIT-keydb-2023-28425, BIT-redis-2023-28425, BIT-valkey-2023-28425, DEBIAN-CVE-2023-28425, GHSA-mvmm-4vq6-vw8c

## What is CVE-2023-28425?

CVE-2023-28425 is a medium-severity denial of service vulnerability in redis, published on 20 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Redis is an in-memory database that persists on disk. Starting in version 7.0.8 and prior to version 7.0.10, authenticated users can use the MSETNX command to trigger a runtime assertion and termination of the Redis server process. The problem is fixed in Redis version 7.0.10.

Weakness: CWE-617 (Reachable Assertion), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2023-28425?

3 open source packages ship an affected version, including redis, keydb and valkey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redis` | Bitnami | From 7.0.8 | 7.0.10 |
| `keydb` | Bitnami | From 7.0.8 | 7.0.10 |
| `valkey` | Bitnami | From 7.0.8 | 7.0.10 |

Products: Redis Redis.

## How do I fix CVE-2023-28425?

Upgrade redis to 7.0.10 or later.

## Is CVE-2023-28425 being exploited?

There is no known exploitation of CVE-2023-28425 in the wild and no public exploit code.

## Other vulnerabilities in redis

- [CVE-2022-0543](https://insights.sbomify.com/CVE-2022-0543/): Debian-specific Redis Server Lua Sandbox Escape (critical 10.0, exploited in the wild)
- [CVE-2026-23479](https://insights.sbomify.com/CVE-2026-23479/): redis-server use-after-free in unblock client flow may allow remote code execution (high 7.7)
- [CVE-2026-25243](https://insights.sbomify.com/CVE-2026-25243/): redis-server RESTORE invalid memory access may allow remote code execution (high 7.7)
- [CVE-2025-62507](https://insights.sbomify.com/CVE-2025-62507/): Redis: Bug in XACKDEL may lead to stack overflow and potential RCE (high 7.7)
- [CVE-2025-48367](https://insights.sbomify.com/CVE-2025-48367/): Redis DoS Vulnerability due to bad connection error handling (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28425 and fix it if it is affected.

What it is: CVE-2023-28425 is a medium-severity denial of service vulnerability in redis, published on 20 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28425 in the wild and no public exploit code.

Affected packages and fixed versions:
- redis (Bitnami): affected from 7.0.8; fixed in 7.0.10
- keydb (Bitnami): affected from 7.0.8; fixed in 7.0.10
- valkey (Bitnami): affected from 7.0.8; fixed in 7.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28425/ (Markdown: https://insights.sbomify.com/CVE-2023-28425/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28425
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28425
- OSV: https://osv.dev/vulnerability/CVE-2023-28425

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28425/
Summaries are generated and may contain mistakes; the official description above is the record.
