{"answers":{"affected":"3 open source packages ship an affected version, including tailscale.com. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28436 in the wild and no public exploit code.","fix":"Upgrade tailscale.com to 1.38.2 or later.","what":"CVE-2023-28436 is a medium-severity vulnerability in tailscale, published on 23 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-28436 and fix it if it is affected.\n\nWhat it is: CVE-2023-28436 is a medium-severity vulnerability in tailscale, published on 23 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-28436 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tailscale.com (Go): affected from 1.34.0; fixed in 1.38.2\n- tailscale.com (Go): affected from 1.34.0; fixed in 1.38.2\n- tailscale.com (Go): affected from 1.34.0; fixed in 1.38.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28436/ (Markdown: https://insights.sbomify.com/CVE-2023-28436/index.md)","id":"CVE-2023-28436","markdown":"https://insights.sbomify.com/CVE-2023-28436/index.md","name":"CVE-2023-28436","record":{"aliases":["GHSA-vfgq-g5x8-g595","GO-2023-1671"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Tailscale SSH","requires_auth":"high_privilege","summary":"Attackers can execute commands with elevated group privileges on FreeBSD hosts using Tailscale SSH due to incorrect group ID handling.","user_interaction":"required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"tailscale","vendor":"tailscale"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Tailscale is software for using Wireguard and multi-factor authentication (MFA). A vulnerability identified in the implementation of Tailscale SSH starting in version 1.34.0 and prior to prior to 1.38.2 in FreeBSD allows commands to be run with a higher privilege group ID than that specified in Tailscale SSH access rules. A difference in the behavior of the FreeBSD `setgroups` system call from POSIX meant that the Tailscale client running on a FreeBSD-based operating system did not appropriately restrict groups on the host when using Tailscale SSH. When accessing a FreeBSD host over Tailscale SSH, the egid of the tailscaled process was used instead of that of the user specified in Tailscale SSH access rules.\n\nTailscale SSH commands may have been run with a higher privilege group ID than that specified in Tailscale SSH access rules if they met all of the following criteria: the destination node was a FreeBSD device with Tailscale SSH enabled; Tailscale SSH access rules permitted access for non-root users; and a non-interactive SSH session was used.\n\nAffected users should upgrade to version 1.38.2 to remediate the issue.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Non-interactive Tailscale SSH sessions on FreeBSD may use the effective group ID of the tailscaled process","id":"CVE-2023-28436","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"privilege_escalation","year":"2023"},"n_packages":3,"n_references":4,"next":{"headline":"SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed","id":"CVE-2023-28437"},"packages":[{"ecosystem":"Go","fixed":["1.38.2"],"introduced":["1.34.0"],"last_affected":[],"package":"tailscale.com","purl":null,"source":"GHSA-vfgq-g5x8-g595"},{"ecosystem":"Go","fixed":["1.38.2"],"introduced":["1.34.0"],"last_affected":[],"package":"tailscale.com","purl":"pkg:golang/tailscale.com","source":"GHSA-vfgq-g5x8-g595"},{"ecosystem":"Go","fixed":["1.38.2"],"introduced":["1.34.0"],"last_affected":[],"package":"tailscale.com","purl":"pkg:golang/tailscale.com","source":"GO-2023-1671"}],"prev":{"headline":"Dataease file upload interface does not verify permission or file type","id":"CVE-2023-28435"},"products":["tailscale"],"published":"2023-03-23","related":[{"cvss_score":9.6,"headline":"Tailscale Windows daemon is vulnerable to RCE via CSRF","id":"CVE-2022-41924","kev_date_added":null,"published":"2022-11-23"},{"cvss_score":3.8,"headline":"Tailscale daemon is vulnerable to information disclosure via CSRF","id":"CVE-2022-41925","kev_date_added":null,"published":"2022-11-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["tailscale"]},"summary":"Attackers can execute commands with elevated group privileges on FreeBSD hosts using Tailscale SSH due to incorrect group ID handling.","url":"https://insights.sbomify.com/CVE-2023-28436/"}