# CVE-2023-28436: Non-interactive Tailscale SSH sessions on FreeBSD may use the effective group ID of the tailscaled process

> Attackers can execute commands with elevated group privileges on FreeBSD hosts using Tailscale SSH due to incorrect group ID handling.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:A/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-vfgq-g5x8-g595, GO-2023-1671

## What is CVE-2023-28436?

CVE-2023-28436 is a medium-severity vulnerability in tailscale, published on 23 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Tailscale is software for using Wireguard and multi-factor authentication (MFA). A vulnerability identified in the implementation of Tailscale SSH starting in version 1.34.0 and prior to prior to 1.38.2 in FreeBSD allows commands to be run with a higher privilege group ID than that specified in Tailscale SSH access rules. A difference in the behavior of the FreeBSD `setgroups` system call from POSIX meant that the Tailscale client running on a FreeBSD-based operating system did not appropriately restrict groups on the host when using Tailscale SSH. When accessing a FreeBSD host over Tailscale SSH, the egid of the tailscaled process was used instead of that of the user specified in Tailscale SSH access rules.

Tailscale SSH commands may have been run with a higher privilege group ID than that specified in Tailscale SSH access rules if they met all of the following criteria: the destination node was a FreeBSD device with Tailscale SSH enabled; Tailscale SSH access rules permitted access for non-root users; and a non-interactive SSH session was used.

Affected users should upgrade to version 1.38.2 to remediate the issue.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-28436?

3 open source packages ship an affected version, including tailscale.com. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tailscale.com` | Go | From 1.34.0 | 1.38.2 |
| `tailscale.com` | Go | From 1.34.0 | 1.38.2 |
| `tailscale.com` | Go | From 1.34.0 | 1.38.2 |

Products: Tailscale Tailscale.

## How do I fix CVE-2023-28436?

Upgrade tailscale.com to 1.38.2 or later.

## Is CVE-2023-28436 being exploited?

There is no known exploitation of CVE-2023-28436 in the wild and no public exploit code.

## Other vulnerabilities in tailscale

- [CVE-2022-41924](https://insights.sbomify.com/CVE-2022-41924/): Tailscale Windows daemon is vulnerable to RCE via CSRF (critical 9.6)
- [CVE-2022-41925](https://insights.sbomify.com/CVE-2022-41925/): Tailscale daemon is vulnerable to information disclosure via CSRF (low 3.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28436 and fix it if it is affected.

What it is: CVE-2023-28436 is a medium-severity vulnerability in tailscale, published on 23 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-28436 in the wild and no public exploit code.

Affected packages and fixed versions:
- tailscale.com (Go): affected from 1.34.0; fixed in 1.38.2
- tailscale.com (Go): affected from 1.34.0; fixed in 1.38.2
- tailscale.com (Go): affected from 1.34.0; fixed in 1.38.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28436/ (Markdown: https://insights.sbomify.com/CVE-2023-28436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28436
- OSV: https://osv.dev/vulnerability/CVE-2023-28436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28436/
Summaries are generated and may contain mistakes; the official description above is the record.
