# CVE-2023-28437: SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed

> Attackers can bypass SQL injection protections in DataEase to read or modify database contents.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Mar 2023
- **Updated:** 19 Feb 2025
- **Also known as:** GHSA-7j7j-9rw6-3r56

## What is CVE-2023-28437?

CVE-2023-28437 is a critical SQL injection vulnerability in Dataease Dataease, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dataease is an open source data visualization and analysis tool. The blacklist for SQL injection protection is missing entries. This vulnerability has been fixed in version 1.18.5. There are no known workarounds.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2023-28437?

It affects 1 product.


Products: Dataease Dataease.

## How do I fix CVE-2023-28437?

No fix has been published for CVE-2023-28437 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-28437 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28437 exists.

## Other vulnerabilities in Dataease Dataease

- [CVE-2024-57707](https://insights.sbomify.com/CVE-2024-57707/): Code injection in n/a (critical 9.8)
- [CVE-2024-46997](https://insights.sbomify.com/CVE-2024-46997/): DataEase's H2 datasource has a remote command execution risk (critical 9.8)
- [CVE-2023-33963](https://insights.sbomify.com/CVE-2023-33963/): DataEase data source has deserialization vulnerability (critical 9.8)
- [CVE-2022-39312](https://insights.sbomify.com/CVE-2022-39312/): Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability (critical 9.8)
- [CVE-2022-34113](https://insights.sbomify.com/CVE-2022-34113/): Dataease before 1.11.2 allows arbitrary code execution via crafter plugin (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28437 and fix it if it is affected.

What it is: CVE-2023-28437 is a critical SQL injection vulnerability in Dataease Dataease, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28437 exists.

Affected product: Dataease Dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28437/ (Markdown: https://insights.sbomify.com/CVE-2023-28437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28437
- OSV: https://osv.dev/vulnerability/CVE-2023-28437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28437/
Summaries are generated and may contain mistakes; the official description above is the record.
