# CVE-2023-28444: angular-server-side-configuration information disclosure vulnerability in monorepo with node.js backend

> In monorepo setups, backend environment variables may be exposed in the frontend index.html due to overly broad detection logic.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2023
- **Updated:** 24 Feb 2025
- **Also known as:** GHSA-gwvm-vrp4-4pp5

## What is CVE-2023-28444?

CVE-2023-28444 is a critical vulnerability in kyubisation angular-server-side-configuration, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

angular-server-side-configuration helps configure an angular application at runtime on the server or in a docker container via environment variables. angular-server-side-configuration detects used environment variables in TypeScript (.ts) files during build time of an Angular CLI project. The detected environment variables are written to a ngssc.json file in the output directory.
During deployment of an Angular based app, the environment variables based on the variables from ngssc.json are inserted into the apps index.html (or defined index file). With version 15.0.0 the environment variable detection was widened to the entire project, relative to the angular.json file from the Angular CLI. In a monorepo setup, this could lead to environment variables intended for a backend/service to be detected and written to the ngssc.json, which would then be populated and exposed via index.html. This has NO IMPACT, in a plain Angular project that has no backend component. This vulnerability has been mitigated in version 15.1.0, by adding an option `searchPattern` which restricts the detection file range by default. As a workaround, manually edit or create ngssc.json or run script after ngssc.json generation.

Weakness: CWE-538 (Insertion of Sensitive Information into Externally-Accessible File or Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-28444?

2 open source packages ship an affected version, including angular-server-side-configuration. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `angular-server-side-configuration` | npm | From 15.0.0 | 15.1.0 |
| `angular-server-side-configuration` | npm | From 15.0.0 | 15.1.0 |

Products: Angular-Server-Side-Configuration Project Angular-Server-Side-Configuration.

## How do I fix CVE-2023-28444?

Upgrade angular-server-side-configuration to 15.1.0 or later.

## Is CVE-2023-28444 being exploited?

There is no known exploitation of CVE-2023-28444 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28444 and fix it if it is affected.

What it is: CVE-2023-28444 is a critical vulnerability in kyubisation angular-server-side-configuration, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28444 in the wild and no public exploit code.

Affected packages and fixed versions:
- angular-server-side-configuration (npm): affected from 15.0.0; fixed in 15.1.0
- angular-server-side-configuration (npm): affected from 15.0.0; fixed in 15.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28444/ (Markdown: https://insights.sbomify.com/CVE-2023-28444/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28444
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28444
- OSV: https://osv.dev/vulnerability/CVE-2023-28444

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28444/
Summaries are generated and may contain mistakes; the official description above is the record.
