# CVE-2023-28445: Deno improperly handles resizable ArrayBuffer

> Out-of-bound read/write in Deno via resizable ArrayBuffers allows potential code execution or crashes, requiring an upgrade to patched versions.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2023
- **Updated:** 20 Feb 2025
- **Also known as:** GHSA-c25x-cm9x-qqgx

## What is CVE-2023-28445?

CVE-2023-28445 is a critical memory corruption vulnerability in denoland deno, published on 23 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Deno is a runtime for JavaScript and TypeScript that uses V8 and is built in Rust. Resizable ArrayBuffers passed to asynchronous functions that are shrunk during the asynchronous operation could result in an out-of-bound read/write. It is unlikely that this has been exploited in the wild, as the only version affected is Deno 1.32.0. Deno Deploy users are not affected. The problem has been resolved by disabling resizable ArrayBuffers temporarily in Deno 1.32.1. Deno 1.32.2 will re-enable resizable ArrayBuffers with a proper fix. As a workaround, run with `--v8-flags=--no-harmony-rab-gsab` to disable resizable ArrayBuffers.

Weakness: CWE-787 (Out-of-bounds Write), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2023-28445?

6 open source packages ship an affected version, including Deno, deno_runtime and serde_v8. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Deno` | crates.io | From 1.32.0 | 1.32.1 |
| `Deno` | crates.io | From 1.32.0 | 1.32.1 |
| `deno_runtime` | crates.io | From 0.102.0 | 0.103.0 |
| `deno_runtime` | crates.io | From 0.102.0 | 0.103.0 |
| `serde_v8` | crates.io | From 0.87.0 | 0.88.0 |
| `serde_v8` | crates.io | From 0.87.0 | 0.88.0 |

Products: Deno Deno, Deno Deno Runtime, Deno Serde V8.

## How do I fix CVE-2023-28445?

Upgrade Deno to 1.32.1 or later.

## Is CVE-2023-28445 being exploited?

There is no known exploitation of CVE-2023-28445 in the wild and no public exploit code.

## Other vulnerabilities in denoland deno

- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)
- [CVE-2023-28446](https://insights.sbomify.com/CVE-2023-28446/): Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28445 and fix it if it is affected.

What it is: CVE-2023-28445 is a critical memory corruption vulnerability in denoland deno, published on 23 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28445 in the wild and no public exploit code.

Affected packages and fixed versions:
- Deno (crates.io): affected from 1.32.0; fixed in 1.32.1
- Deno (crates.io): affected from 1.32.0; fixed in 1.32.1
- deno_runtime (crates.io): affected from 0.102.0; fixed in 0.103.0
- deno_runtime (crates.io): affected from 0.102.0; fixed in 0.103.0
- serde_v8 (crates.io): affected from 0.87.0; fixed in 0.88.0
- serde_v8 (crates.io): affected from 0.87.0; fixed in 0.88.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28445/ (Markdown: https://insights.sbomify.com/CVE-2023-28445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28445
- OSV: https://osv.dev/vulnerability/CVE-2023-28445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28445/
Summaries are generated and may contain mistakes; the official description above is the record.
