# CVE-2023-28446: Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization

> Attackers can spoof Deno's interactive permission prompts using ANSI escape sequences to trick users into executing arbitrary code.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Mar 2023
- **Updated:** 19 Feb 2025
- **Also known as:** GHSA-vq67-rp93-65qf, JLSEC-2026-102

## What is CVE-2023-28446?

CVE-2023-28446 is a high-severity vulnerability in denoland deno, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Deno is a simple, modern and secure runtime for JavaScript and TypeScript that uses V8 and is built in Rust. Arbitrary program names without any ANSI filtering allows any malicious program to clear the first 2 lines of a `op_spawn_child` or `op_kill` prompt and replace it with any desired text. This works with any command on the respective platform, giving the program the full ability to choose what program they wanted to run. This problem can not be exploited on systems that do not attach an interactive prompt (for example headless servers). This issue has been patched in version 1.31.2.

Weakness: CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences)

## Which versions are affected by CVE-2023-28446?

4 open source packages ship an affected version, including deno and deno_runtime. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | From 1.8.0 | 1.31.2 |
| `deno` | crates.io | From 1.8.0 | 1.31.2 |
| `deno_runtime` | crates.io | From 1.8.0 | 1.31.2 |
| `deno_runtime` | crates.io | From 1.8.0 | 1.31.2 |

Products: Deno Deno.

## How do I fix CVE-2023-28446?

Upgrade deno to 1.31.2 or later.

## Is CVE-2023-28446 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28446 exists.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28446 and fix it if it is affected.

What it is: CVE-2023-28446 is a high-severity vulnerability in denoland deno, published on 24 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28446 exists.

Affected packages and fixed versions:
- deno (crates.io): affected from 1.8.0; fixed in 1.31.2
- deno (crates.io): affected from 1.8.0; fixed in 1.31.2
- deno_runtime (crates.io): affected from 1.8.0; fixed in 1.31.2
- deno_runtime (crates.io): affected from 1.8.0; fixed in 1.31.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28446/ (Markdown: https://insights.sbomify.com/CVE-2023-28446/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28446
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28446
- OSV: https://osv.dev/vulnerability/CVE-2023-28446

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28446/
Summaries are generated and may contain mistakes; the official description above is the record.
