{"answers":{"affected":"3 open source packages ship an affected version, including versionize. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28448 in the wild and no public exploit code.","fix":"Upgrade versionize to 0.1.10 or later.","what":"CVE-2023-28448 is a medium-severity memory corruption vulnerability in firecracker-microvm versionize, published on 24 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-28448 and fix it if it is affected.\n\nWhat it is: CVE-2023-28448 is a medium-severity memory corruption vulnerability in firecracker-microvm versionize, published on 24 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-28448 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- versionize (crates.io): affected from 0.0.0-0; fixed in 0.1.10\n- versionize (crates.io): affected from 0.1.1; fixed in 0.1.10\n- versionize (crates.io): affected from 0.1.1; fixed in 0.1.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28448/ (Markdown: https://insights.sbomify.com/CVE-2023-28448/index.md)","id":"CVE-2023-28448","markdown":"https://insights.sbomify.com/CVE-2023-28448/index.md","name":"CVE-2023-28448","record":{"aliases":["AZL-25843","GHSA-8vxc-r5wp-vgvc","RUSTSEC-2023-0030"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Rust serialization library","requires_auth":"none","summary":"Attackers can trigger out-of-bounds memory access via crafted serialized data, potentially causing crashes or code execution in applications using the versionize crate.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"versionize","vendor":"versionize_project"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Versionize is a framework for version tolerant serializion/deserialization of Rust data structures, designed for usecases that need fast deserialization times and minimal size overhead. An issue was discovered in the ‘Versionize::deserialize’ implementation provided by the ‘versionize’ crate for ‘vmm_sys_utils::fam::FamStructWrapper', which can lead to out of bounds memory accesses. The impact started with version 0.1.1. The issue was corrected in version 0.1.10 by inserting a check that verifies, for any deserialized header, the lengths of compared flexible arrays are equal and aborting deserialization otherwise.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Versionize is lacking bound checks, potentially leading to out of bounds memory access","id":"CVE-2023-28448","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2023-28450"},"packages":[{"ecosystem":"crates.io","fixed":["0.1.10"],"introduced":["0.0.0-0"],"last_affected":[],"package":"versionize","purl":"pkg:cargo/versionize","source":"RUSTSEC-2023-0030"},{"ecosystem":"crates.io","fixed":["0.1.10"],"introduced":["0.1.1"],"last_affected":[],"package":"versionize","purl":null,"source":"GHSA-8vxc-r5wp-vgvc"},{"ecosystem":"crates.io","fixed":["0.1.10"],"introduced":["0.1.1"],"last_affected":[],"package":"versionize","purl":"pkg:cargo/versionize","source":"GHSA-8vxc-r5wp-vgvc"}],"prev":{"headline":"Cross site scripting vulnerability in Javascript escaping in smarty/smarty","id":"CVE-2023-28447"},"products":["versionize"],"published":"2023-03-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-19","vendors":["firecracker-microvm"]},"summary":"Attackers can trigger out-of-bounds memory access via crafted serialized data, potentially causing crashes or code execution in applications using the versionize crate.","url":"https://insights.sbomify.com/CVE-2023-28448/"}