# CVE-2023-28459: pretalx vulnerable to path traversal in HTML export

> Attackers can read arbitrary files via crafted HTML uploads in the non-default HTML export feature of pretalx.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2023
- **Updated:** 5 Feb 2025
- **Also known as:** GHSA-wh3w-jcc7-mhmf, PYSEC-2023-41

## What is CVE-2023-28459?

CVE-2023-28459 is a medium-severity path traversal vulnerability in n/a, published on 20 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pretalx 2.3.1 before 2.3.2 allows path traversal in HTML export (a non-default feature). Users were able to upload crafted HTML documents that trigger the reading of arbitrary files.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-28459?

3 open source packages ship an affected version, including pretalx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pretalx` | PyPI | All versions | 2.3.2 |
| `pretalx` | PyPI | All versions | 2.3.2 |
| `pretalx` | PyPI | From 2.3.1 | 2.3.2 |

Products: Pretalx Pretalx.

## How do I fix CVE-2023-28459?

Upgrade pretalx to 2.3.2 or later.

## Is CVE-2023-28459 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28459 exists.

Public exploit code:

- Pretalx Arbitrary File Read/Limited File Write (metasploit)

## Other vulnerabilities in n/a

- [CVE-2026-41241](https://insights.sbomify.com/CVE-2026-41241/): pretalx: Stored cross-site scripting in organiser search typeahead (high 8.7)
- [CVE-2026-41426](https://insights.sbomify.com/CVE-2026-41426/): pretalx: Email injection via unescaped user-controlled placeholders in pretalx mail templates (medium 6.1)
- [CVE-2023-28458](https://insights.sbomify.com/CVE-2023-28458/): pretalx allows path traversal in HTML export (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28459 and fix it if it is affected.

What it is: CVE-2023-28459 is a medium-severity path traversal vulnerability in n/a, published on 20 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28459 exists.

Affected packages and fixed versions:
- pretalx (PyPI): affected all versions; fixed in 2.3.2
- pretalx (PyPI): affected all versions; fixed in 2.3.2
- pretalx (PyPI): affected from 2.3.1; fixed in 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28459/ (Markdown: https://insights.sbomify.com/CVE-2023-28459/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28459
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28459
- OSV: https://osv.dev/vulnerability/CVE-2023-28459

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28459/
Summaries are generated and may contain mistakes; the official description above is the record.
