# CVE-2023-28460: Command injection in n/a

> Remote administrators can execute arbitrary shell code via crafted packets in Array Networks APV products.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Mar 2023
- **Updated:** 27 Feb 2025
- **Also known as:** GHSA-rrg8-hxw6-gqx4

## What is CVE-2023-28460?

CVE-2023-28460 is a high-severity command injection vulnerability in n/a, published on 15 Mar 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A command injection vulnerability was discovered in Array Networks APV products. A remote attacker can send a crafted packet after logging into the affected appliance as an administrator, resulting in arbitrary shell code execution. This is fixed in 8.6.1.262 or newer and 10.4.2.93 or newer.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2023-28460?

It affects 1 product.


Products: Arraynetworks Array Os.

## How do I fix CVE-2023-28460?

No fix has been published for CVE-2023-28460 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-28460 being exploited?

There is no known exploitation of CVE-2023-28460 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28460 and fix it if it is affected.

What it is: CVE-2023-28460 is a high-severity command injection vulnerability in n/a, published on 15 Mar 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28460 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28460/ (Markdown: https://insights.sbomify.com/CVE-2023-28460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28460
- OSV: https://osv.dev/vulnerability/CVE-2023-28460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28460/
Summaries are generated and may contain mistakes; the official description above is the record.
