{"answers":{"affected":"2 open source packages ship an affected version, including fish.payara.server:payara-aggregator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28462 in the wild and no public exploit code.","fix":"Upgrade fish.payara.server:payara-aggregator to 6.2022.1.Alpha3 or later.","what":"CVE-2023-28462 is a critical unsafe deserialization vulnerability in n/a, published on 30 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-28462 and fix it if it is affected.\n\nWhat it is: CVE-2023-28462 is a critical unsafe deserialization vulnerability in n/a, published on 30 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-28462 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fish.payara.server:payara-aggregator (Maven): affected from 5.2020.1; fixed in 6.2022.1.Alpha3\n- fish.payara.server:payara-aggregator (Maven): affected from 5.2020.1; fixed in 6.2022.1.Alpha3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28462/ (Markdown: https://insights.sbomify.com/CVE-2023-28462/index.md)","id":"CVE-2023-28462","markdown":"https://insights.sbomify.com/CVE-2023-28462/index.md","name":"CVE-2023-28462","record":{"aliases":["GHSA-xc93-587g-mxm7"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Payara Application Server","requires_auth":"none","summary":"Remote attackers can execute malicious code on Payara Server via JNDI rebind operations when using older Java versions.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"payara_server","vendor":"payara"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A JNDI rebind operation in the default ORB listener in Payara Server 4.1.2.191 (Enterprise), 5.20.0 and newer (Enterprise), and 5.2020.1 and newer (Community), when Java 1.8u181 and earlier is used, allows remote attackers to load malicious code on the server once a JNDI directory scan is performed.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Payara Server allows remote attackers to load malicious code on the server once a JNDI directory scan is performed","id":"CVE-2023-28462","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Use after free in n/a","id":"CVE-2023-28464"},"packages":[{"ecosystem":"Maven","fixed":["6.2022.1.Alpha3"],"introduced":["5.2020.1"],"last_affected":[],"package":"fish.payara.server:payara-aggregator","purl":null,"source":"GHSA-xc93-587g-mxm7"},{"ecosystem":"Maven","fixed":["6.2022.1.Alpha3"],"introduced":["5.2020.1"],"last_affected":[],"package":"fish.payara.server:payara-aggregator","purl":"pkg:maven/fish.payara.server/payara-aggregator","source":"GHSA-xc93-587g-mxm7"}],"prev":{"headline":"Array Networks AG and vxAG ArrayOS Missing Authentication for Critical Function","id":"CVE-2023-28461"},"products":["n/a"],"published":"2023-03-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-18","vendors":["n/a"]},"summary":"Remote attackers can execute malicious code on Payara Server via JNDI rebind operations when using older Java versions.","url":"https://insights.sbomify.com/CVE-2023-28462/"}