# CVE-2023-28462: Payara Server allows remote attackers to load malicious code on the server once a JNDI directory scan is performed

> Remote attackers can execute malicious code on Payara Server via JNDI rebind operations when using older Java versions.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2023
- **Updated:** 18 Feb 2025
- **Also known as:** GHSA-xc93-587g-mxm7

## What is CVE-2023-28462?

CVE-2023-28462 is a critical unsafe deserialization vulnerability in n/a, published on 30 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A JNDI rebind operation in the default ORB listener in Payara Server 4.1.2.191 (Enterprise), 5.20.0 and newer (Enterprise), and 5.2020.1 and newer (Community), when Java 1.8u181 and earlier is used, allows remote attackers to load malicious code on the server once a JNDI directory scan is performed.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-28462?

2 open source packages ship an affected version, including fish.payara.server:payara-aggregator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fish.payara.server:payara-aggregator` | Maven | From 5.2020.1 | 6.2022.1.Alpha3 |
| `fish.payara.server:payara-aggregator` | Maven | From 5.2020.1 | 6.2022.1.Alpha3 |

Products: Payara Payara Server.

## How do I fix CVE-2023-28462?

Upgrade fish.payara.server:payara-aggregator to 6.2022.1.Alpha3 or later.

## Is CVE-2023-28462 being exploited?

There is no known exploitation of CVE-2023-28462 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28462 and fix it if it is affected.

What it is: CVE-2023-28462 is a critical unsafe deserialization vulnerability in n/a, published on 30 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28462 in the wild and no public exploit code.

Affected packages and fixed versions:
- fish.payara.server:payara-aggregator (Maven): affected from 5.2020.1; fixed in 6.2022.1.Alpha3
- fish.payara.server:payara-aggregator (Maven): affected from 5.2020.1; fixed in 6.2022.1.Alpha3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28462/ (Markdown: https://insights.sbomify.com/CVE-2023-28462/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28462
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28462
- OSV: https://osv.dev/vulnerability/CVE-2023-28462

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28462/
Summaries are generated and may contain mistakes; the official description above is the record.
