CVE-2023-28474 Stored cross site scripting on saved presets
Attackers can inject malicious scripts via saved search presets in Concrete CMS, potentially executing code in victim browsers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-28474?
CVE-2023-28474 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 28 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Concrete CMS (previously concrete5) in versions 9.0 through 9.1.3 is vulnerable to Stored XSS on Saved Presets on search.
Weakness: CWE-79
Which versions are affected by CVE-2023-28474?
2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
concrete5/concrete5 Packagist | All versions | 9.2.0 |
concrete5/concrete5 Packagist | All versions | 9.2.0 |
Products include Concretecms Concrete Cms.
How do I fix CVE-2023-28474?
Upgrade concrete5/concrete5 to 9.2.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-28474 being exploited?
There is no known exploitation of CVE-2023-28474 in the wild and no public exploit code.
Other vulnerabilities in Concretecms Concrete Cms
- CVE-2023-48648 Concrete CMS allows unauthorized access because directories can be created with insecure permissions
- CVE-2022-21829 Code injection in concrete CMS
- CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5
- CVE-2021-40098 Path traversal in n/a
- CVE-2026-8134 Concrete CMS Vulnerable to Relative Path Traversal
Sources
Also known as GHSA-2j26-j953-2rph.