CVE-2023-28475 Reflected cross site scripting

Medium 6.1 Published Updated

Attackers can execute arbitrary scripts in victim browsers via unsanitized input in the Concrete CMS reply form.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-28475?

CVE-2023-28475 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 28 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Concrete CMS (previously concrete5) versions 8.5.12 and below, and versions 9.0 through 9.1.3 is vulnerable to Reflected XSS on the Reply form because msgID was not sanitized.

Weakness: CWE-79

Which versions are affected by CVE-2023-28475?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistAll versions9.2.0
concrete5/concrete5 PackagistAll versions9.2.0

Products include Concretecms Concrete Cms.

How do I fix CVE-2023-28475?

Upgrade concrete5/concrete5 to 9.2.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-28475 being exploited?

There is no known exploitation of CVE-2023-28475 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-vcpr-hm2m-gjjj.

Is CVE-2023-28475 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free