CVE-2023-28477 Stored cross site scripting on API integration
Attackers can inject malicious scripts via the API Integrations name parameter, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-28477?
CVE-2023-28477 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 28 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Concrete CMS (previously concrete5) versions 8.5.12 and below, and 9.0 through 9.1.3 is vulnerable to stored XSS on API Integrations via the name parameter.
Weakness: CWE-79
Which versions are affected by CVE-2023-28477?
2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
concrete5/concrete5 Packagist | All versions | 9.2.0 |
concrete5/concrete5 Packagist | All versions | 9.2.0 |
Products include Concretecms Concrete Cms.
How do I fix CVE-2023-28477?
Upgrade concrete5/concrete5 to 9.2.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-28477 being exploited?
There is no known exploitation of CVE-2023-28477 in the wild and no public exploit code.
Other vulnerabilities in Concretecms Concrete Cms
- CVE-2023-48648 Concrete CMS allows unauthorized access because directories can be created with insecure permissions
- CVE-2022-21829 Code injection in concrete CMS
- CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5
- CVE-2021-40098 Path traversal in n/a
- CVE-2026-8134 Concrete CMS Vulnerable to Relative Path Traversal
Sources
Also known as GHSA-xfmj-r86m-j2hr.