{"answers":{"affected":"2 open source packages ship an affected version, including wordpress-multisite and wordpress.","exploited":"There is no known exploitation of CVE-2023-28492 in the wild and no public exploit code.","fix":"Upgrade wordpress-multisite to 1.4.11 or later.","what":"CVE-2023-28492 is a medium-severity missing authorization vulnerability in CodePeople CP Multi View Event Calendar, published on 3 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-28492 and fix it if it is affected.\n\nWhat it is: CVE-2023-28492 is a medium-severity missing authorization vulnerability in CodePeople CP Multi View Event Calendar, published on 3 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-28492 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress-multisite (Bitnami): affected all versions; fixed in 1.4.11\n- wordpress (Bitnami): affected all versions; fixed in 1.4.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28492/ (Markdown: https://insights.sbomify.com/CVE-2023-28492/index.md)","id":"CVE-2023-28492","markdown":"https://insights.sbomify.com/CVE-2023-28492/index.md","name":"CVE-2023-28492","record":{"aliases":["BIT-wordpress-2023-28492","BIT-wordpress-multisite-2023-28492","GHSA-439r-69x2-2r66"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Attackers can submit feedback without authorization due to missing checks in the CP Multi View Event Calendar plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Missing Authorization vulnerability in CodePeople CP Multi View Event Calendar allows Functionality Misuse.This issue affects CP Multi View Event Calendar: from n/a through 1.4.10.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing authorization in CP Multi View Event Calendar","id":"CVE-2023-28492","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"WordPress Newsmag Theme \u003c= 2.4.4 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-28493"},"packages":[{"ecosystem":"Bitnami","fixed":["1.4.11"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2023-28492"},{"ecosystem":"Bitnami","fixed":["1.4.11"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2023-28492"}],"prev":{"headline":"WordPress Slideshow Gallery Plugin \u003c= 1.7.6 is vulnerable to SQL Injection","id":"CVE-2023-28491"},"products":["CP Multi View Event Calendar"],"published":"2024-06-03","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-28","vendors":["CodePeople"]},"summary":"Attackers can submit feedback without authorization due to missing checks in the CP Multi View Event Calendar plugin.","url":"https://insights.sbomify.com/CVE-2023-28492/"}