{"answers":{"affected":"2 open source packages ship an affected version, including github.com/ansible-semaphore/semaphore. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28609 in the wild and no public exploit code.","fix":"Upgrade github.com/ansible-semaphore/semaphore to 2.8.89 or later.","what":"CVE-2023-28609 is a critical authentication bypass vulnerability in n/a, published on 18 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-28609 and fix it if it is affected.\n\nWhat it is: CVE-2023-28609 is a critical authentication bypass vulnerability in n/a, published on 18 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-28609 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/ansible-semaphore/semaphore (Go): affected all versions; fixed in 2.8.89\n- github.com/ansible-semaphore/semaphore (Go): affected all versions; fixed in 2.8.89\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28609/ (Markdown: https://insights.sbomify.com/CVE-2023-28609/index.md)","id":"CVE-2023-28609","markdown":"https://insights.sbomify.com/CVE-2023-28609/index.md","name":"CVE-2023-28609","record":{"aliases":["GHSA-pmhg-cmjc-3875"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ansible Semaphore","requires_auth":"none","summary":"Attackers can bypass authentication in Ansible Semaphore due to mishandled auth logic, requiring an upgrade to secure the application.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ansible_semaphore","vendor":"ansible-semaphore"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"api/auth.go in Ansible Semaphore before 2.8.89 mishandles authentication.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ansible Semaphore mishandles authentication","id":"CVE-2023-28609","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Missing authorization in n/a","id":"CVE-2023-28610"},"packages":[{"ecosystem":"Go","fixed":["2.8.89"],"introduced":["0"],"last_affected":[],"package":"github.com/ansible-semaphore/semaphore","purl":null,"source":"GHSA-pmhg-cmjc-3875"},{"ecosystem":"Go","fixed":["2.8.89"],"introduced":["0"],"last_affected":[],"package":"github.com/ansible-semaphore/semaphore","purl":"pkg:golang/github.com/ansible-semaphore/semaphore","source":"GHSA-pmhg-cmjc-3875"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2023-28607"},"products":["n/a"],"published":"2023-03-18","related":[{"cvss_score":8.8,"headline":"Code injection in ansible semaphore","id":"CVE-2023-39059","kev_date_added":null,"published":"2023-08-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-26","vendors":["n/a"]},"summary":"Attackers can bypass authentication in Ansible Semaphore due to mishandled auth logic, requiring an upgrade to secure the application.","url":"https://insights.sbomify.com/CVE-2023-28609/"}