# CVE-2023-28626: Quadratic runtime when parsing Markdown in comrak

> Attackers can cause denial of service in applications using the comrak Rust library by submitting crafted Markdown input that triggers quadratic parsing time.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2023
- **Updated:** 18 Feb 2025
- **Also known as:** GHSA-8hqf-xjwp-p67v

## What is CVE-2023-28626?

CVE-2023-28626 is a medium-severity denial of service vulnerability in kivikakk comrak, published on 28 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

comrak is a CommonMark + GFM compatible Markdown parser and renderer written in rust. A range of quadratic parsing issues are present in Comrak. These can be used to craft denial-of-service attacks on services that use Comrak to parse Markdown. This issue has been addressed in version 0.17.0. Users are advised to upgrade. There are no known workarounds for this vulnerability. This issue is also tracked as `GHSL-2023-047`

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-28626?

2 open source packages ship an affected version, including comrak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `comrak` | crates.io | All versions | 0.17.0 |
| `comrak` | crates.io | All versions | 0.17.0 |

Products: Comrak Project Comrak.

## How do I fix CVE-2023-28626?

Upgrade comrak to 0.17.0 or later.

## Is CVE-2023-28626 being exploited?

There is no known exploitation of CVE-2023-28626 in the wild and no public exploit code.

## Other vulnerabilities in kivikakk comrak

- [CVE-2021-38186](https://insights.sbomify.com/CVE-2021-38186/): Cross-site Scripting in comrak (medium 6.1)
- [CVE-2021-27671](https://insights.sbomify.com/CVE-2021-27671/): Cross site scripting in comrak (medium 6.1)
- [CVE-2023-28631](https://insights.sbomify.com/CVE-2023-28631/): Attacker controlled data in AST nodes is not validated in comrak (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28626 and fix it if it is affected.

What it is: CVE-2023-28626 is a medium-severity denial of service vulnerability in kivikakk comrak, published on 28 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28626 in the wild and no public exploit code.

Affected packages and fixed versions:
- comrak (crates.io): affected all versions; fixed in 0.17.0
- comrak (crates.io): affected all versions; fixed in 0.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28626/ (Markdown: https://insights.sbomify.com/CVE-2023-28626/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28626
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28626
- OSV: https://osv.dev/vulnerability/CVE-2023-28626

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28626/
Summaries are generated and may contain mistakes; the official description above is the record.
