{"answers":{"affected":"2 open source packages ship an affected version, including lambdaisland:uri. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28628 exists.","fix":"Upgrade lambdaisland:uri to 1.14.120 or later.","what":"CVE-2023-28628 is a medium-severity vulnerability in lambdaisland uri, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-28628 and fix it if it is affected.\n\nWhat it is: CVE-2023-28628 is a medium-severity vulnerability in lambdaisland uri, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28628 exists.\n\nAffected packages and fixed versions:\n- lambdaisland:uri (Maven): affected all versions; fixed in 1.14.120\n- lambdaisland:uri (Maven): affected all versions; fixed in 1.14.120\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28628/ (Markdown: https://insights.sbomify.com/CVE-2023-28628/index.md)","id":"CVE-2023-28628","markdown":"https://insights.sbomify.com/CVE-2023-28628/index.md","name":"CVE-2023-28628","record":{"aliases":["DEBIAN-CVE-2023-28628","GHSA-cp4w-6x4w-v2h5","UBUNTU-CVE-2023-28628","USN-8151-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Clojure URI library","requires_auth":"none","summary":"Attackers can craft URLs that bypass host restrictions by exploiting incorrect authority parsing in the lambdaisland/uri library.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"uri","vendor":"lambdaisland"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"},{"id":"CWE-706","name":"Use of Incorrectly-Resolved Name or Reference"}],"description":"lambdaisland/uri is a pure Clojure/ClojureScript URI library. In versions prior to 1.14.120 `authority-regex` allows an attacker to send malicious URLs to be parsed by the `lambdaisland/uri` and return the wrong authority. This issue is similar to but distinct from CVE-2020-8910. The regex in question doesn't handle the backslash (`\\`) character in the username correctly, leading to a wrong output. ex. a payload of `https://example.com\\\\@google.com` would return that the host is `google.com`, but the correct host should be `example.com`. Given that the library returns the wrong authority this may be abused to bypass host restrictions depending on how the library is used in an application. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"`authority-regex` returns the wrong authority in lambdaisland/uri","id":"CVE-2023-28628","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"open_redirect","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Stored XSS possible on VSM and Job Details pages via malicious pipeline label configuration in gocd","id":"CVE-2023-28629"},"packages":[{"ecosystem":"Maven","fixed":["1.14.120"],"introduced":["0"],"last_affected":[],"package":"lambdaisland:uri","purl":null,"source":"GHSA-cp4w-6x4w-v2h5"},{"ecosystem":"Maven","fixed":["1.14.120"],"introduced":["0"],"last_affected":[],"package":"lambdaisland:uri","purl":"pkg:maven/lambdaisland/uri","source":"GHSA-cp4w-6x4w-v2h5"}],"prev":{"headline":"OS Command Injection via GIT_PATH in pymedusa","id":"CVE-2023-28627"},"products":["uri"],"published":"2023-03-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-19","vendors":["lambdaisland"]},"summary":"Attackers can craft URLs that bypass host restrictions by exploiting incorrect authority parsing in the lambdaisland/uri library.","url":"https://insights.sbomify.com/CVE-2023-28628/"}