{"answers":{"affected":"2 open source packages ship an affected version, including comrak. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28631 in the wild and no public exploit code.","fix":"Upgrade comrak to 0.17.0 or later.","what":"CVE-2023-28631 is a medium-severity vulnerability in kivikakk comrak, published on 28 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-28631 and fix it if it is affected.\n\nWhat it is: CVE-2023-28631 is a medium-severity vulnerability in kivikakk comrak, published on 28 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-28631 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- comrak (crates.io): affected all versions; fixed in 0.17.0\n- comrak (crates.io): affected all versions; fixed in 0.17.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28631/ (Markdown: https://insights.sbomify.com/CVE-2023-28631/index.md)","id":"CVE-2023-28631","markdown":"https://insights.sbomify.com/CVE-2023-28631/index.md","name":"CVE-2023-28631","record":{"aliases":["GHSA-5r3x-p7xx-x6q5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust Markdown parser","requires_auth":"none","summary":"Attackers can cause crashes or undefined behavior in the comrak Rust library by providing invalid UTF-8 data in manually constructed AST nodes.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"comrak","vendor":"comrak_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-755","name":"Improper Handling of Exceptional Conditions"}],"description":"comrak is a CommonMark + GFM compatible Markdown parser and renderer written in rust. A Comrak AST can be constructed manually by a program instead of parsing a Markdown document with `parse_document`. This AST can then be converted to HTML via `html::format_document_with_plugins`. However, the HTML formatting code assumes that the AST is well-formed. For example, many AST notes contain `[u8]` fields which the formatting code assumes is valid UTF-8 data. Several bugs can be triggered if this is not the case. Version 0.17.0 contains adjustments to the AST, storing strings instead of unvalidated byte arrays. Users are advised to upgrade. Users unable to upgrade may manually validate UTF-8 correctness of all data when assigning to `\u0026[u8]` and `Vec\u003cu8\u003e` fields in the AST. This issue is also tracked as `GHSL-2023-049`.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Attacker controlled data in AST nodes is not validated in comrak","id":"CVE-2023-28631","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"other","year":"2023"},"n_packages":2,"n_references":5,"next":{"headline":"GLPI vulnerable to account takeover by authenticated user","id":"CVE-2023-28632"},"packages":[{"ecosystem":"crates.io","fixed":["0.17.0"],"introduced":["0"],"last_affected":[],"package":"comrak","purl":null,"source":"GHSA-5r3x-p7xx-x6q5"},{"ecosystem":"crates.io","fixed":["0.17.0"],"introduced":["0"],"last_affected":[],"package":"comrak","purl":"pkg:cargo/comrak","source":"GHSA-5r3x-p7xx-x6q5"}],"prev":{"headline":"Sensitive information disclosure possible on misconfigured failed backups of non-H2 databases in gocd","id":"CVE-2023-28630"},"products":["comrak"],"published":"2023-03-28","related":[{"cvss_score":6.1,"headline":"Cross-site Scripting in comrak","id":"CVE-2021-38186","kev_date_added":null,"published":"2021-08-08"},{"cvss_score":6.1,"headline":"Cross site scripting in comrak","id":"CVE-2021-27671","kev_date_added":null,"published":"2021-02-25"},{"cvss_score":5.3,"headline":"Quadratic runtime when parsing Markdown in comrak","id":"CVE-2023-28626","kev_date_added":null,"published":"2023-03-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-18","vendors":["kivikakk"]},"summary":"Attackers can cause crashes or undefined behavior in the comrak Rust library by providing invalid UTF-8 data in manually constructed AST nodes.","url":"https://insights.sbomify.com/CVE-2023-28631/"}