# CVE-2023-28631: Attacker controlled data in AST nodes is not validated in comrak

> Attackers can cause crashes or undefined behavior in the comrak Rust library by providing invalid UTF-8 data in manually constructed AST nodes.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2023
- **Updated:** 18 Feb 2025
- **Also known as:** GHSA-5r3x-p7xx-x6q5

## What is CVE-2023-28631?

CVE-2023-28631 is a medium-severity vulnerability in kivikakk comrak, published on 28 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

comrak is a CommonMark + GFM compatible Markdown parser and renderer written in rust. A Comrak AST can be constructed manually by a program instead of parsing a Markdown document with `parse_document`. This AST can then be converted to HTML via `html::format_document_with_plugins`. However, the HTML formatting code assumes that the AST is well-formed. For example, many AST notes contain `[u8]` fields which the formatting code assumes is valid UTF-8 data. Several bugs can be triggered if this is not the case. Version 0.17.0 contains adjustments to the AST, storing strings instead of unvalidated byte arrays. Users are advised to upgrade. Users unable to upgrade may manually validate UTF-8 correctness of all data when assigning to `&[u8]` and `Vec<u8>` fields in the AST. This issue is also tracked as `GHSL-2023-049`.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2023-28631?

2 open source packages ship an affected version, including comrak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `comrak` | crates.io | All versions | 0.17.0 |
| `comrak` | crates.io | All versions | 0.17.0 |

Products: Comrak Project Comrak.

## How do I fix CVE-2023-28631?

Upgrade comrak to 0.17.0 or later.

## Is CVE-2023-28631 being exploited?

There is no known exploitation of CVE-2023-28631 in the wild and no public exploit code.

## Other vulnerabilities in kivikakk comrak

- [CVE-2021-38186](https://insights.sbomify.com/CVE-2021-38186/): Cross-site Scripting in comrak (medium 6.1)
- [CVE-2021-27671](https://insights.sbomify.com/CVE-2021-27671/): Cross site scripting in comrak (medium 6.1)
- [CVE-2023-28626](https://insights.sbomify.com/CVE-2023-28626/): Quadratic runtime when parsing Markdown in comrak (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28631 and fix it if it is affected.

What it is: CVE-2023-28631 is a medium-severity vulnerability in kivikakk comrak, published on 28 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28631 in the wild and no public exploit code.

Affected packages and fixed versions:
- comrak (crates.io): affected all versions; fixed in 0.17.0
- comrak (crates.io): affected all versions; fixed in 0.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28631/ (Markdown: https://insights.sbomify.com/CVE-2023-28631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28631
- OSV: https://osv.dev/vulnerability/CVE-2023-28631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28631/
Summaries are generated and may contain mistakes; the official description above is the record.
