# CVE-2023-28635: Defining resource name as integer in vantage6 may give unintended access

> Attackers can gain unauthorized access to resources by creating names that collide with internal IDs, bypassing access controls in vantage6.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Oct 2023
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-7x94-6g2m-3hp2, PYSEC-2023-198, PYSEC-2026-2006

## What is CVE-2023-28635?

CVE-2023-28635 is a medium-severity authentication bypass vulnerability in vantage6, published on 11 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vantage6 is privacy preserving federated learning infrastructure. Prior to version 4.0.0, malicious users may try to get access to resources they are not allowed to see, by creating resources with integers as names. One example where this is a risk, is when users define which users are allowed to run algorithms on their node. This may be defined by username or user id. Now, for example, if user id 13 is allowed to run tasks, and an attacker creates a username with username '13', they would be wrongly allowed to run an algorithm. There may also be other places in the code where such a mixup of resource ID or name leads to issues. Version 4.0.0 contains a patch for this issue. The best solution is to check when resources are created or modified, that the resource name always starts with a character.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-28635?

4 open source packages ship an affected version, including vantage6 and vantage6-node. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6` | PyPI | All versions | 4.0.0 |
| `vantage6` | PyPI | All versions | 4.0.0 |
| `vantage6` | PyPI | All versions | 4.0.0 |
| `vantage6-node` | PyPI | All versions | 4.0.0 |

Products: Vantage6 Vantage6.

## How do I fix CVE-2023-28635?

Upgrade vantage6 to 4.0.0 or later.

## Is CVE-2023-28635 being exploited?

There is no known exploitation of CVE-2023-28635 in the wild and no public exploit code.

## Other vulnerabilities in vantage6

- [CVE-2024-21649](https://insights.sbomify.com/CVE-2024-21649/): Remote code execution (high 8.8)
- [CVE-2023-23929](https://insights.sbomify.com/CVE-2023-23929/): Refresh tokens do not expire in Vantage6 (high 8.8)
- [CVE-2023-47631](https://insights.sbomify.com/CVE-2023-47631/): vantage6 Node accepts non-whitelisted algorithms from malicious server (high 7.2)
- [CVE-2024-21653](https://insights.sbomify.com/CVE-2024-21653/): vantage6 insecure SSH configuration for node and server containers (medium 6.5)
- [CVE-2023-22738](https://insights.sbomify.com/CVE-2023-22738/): Improper Preservation of Permissions in vantage6 (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28635 and fix it if it is affected.

What it is: CVE-2023-28635 is a medium-severity authentication bypass vulnerability in vantage6, published on 11 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28635 in the wild and no public exploit code.

Affected packages and fixed versions:
- vantage6 (PyPI): affected all versions; fixed in 4.0.0
- vantage6 (PyPI): affected all versions; fixed in 4.0.0
- vantage6 (PyPI): affected all versions; fixed in 4.0.0
- vantage6-node (PyPI): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28635/ (Markdown: https://insights.sbomify.com/CVE-2023-28635/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28635
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28635
- OSV: https://osv.dev/vulnerability/CVE-2023-28635

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28635/
Summaries are generated and may contain mistakes; the official description above is the record.
