CVE-2023-28636 GLPI vulnerable to stored Cross-site Scripting in external links
An administrator can inject malicious scripts via external links, potentially leading to code execution or account takeover in GLPI.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2023-28636?
CVE-2023-28636 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 5 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
GLPI is a free asset and IT management software package. Starting in version 0.60 and prior to versions 9.5.13 and 10.0.7, a vulnerability allows an administrator to create a malicious external link. This issue is fixed in versions 9.5.13 and 10.0.7.
Weakness: CWE-79
Which versions are affected by CVE-2023-28636?
It affects 1 product.
Products include Glpi-Project Glpi.
How do I fix CVE-2023-28636?
No fix has been published for CVE-2023-28636 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-28636 being exploited?
There is no known exploitation of CVE-2023-28636 in the wild and no public exploit code.
Other vulnerabilities in Glpi-Project Glpi
- CVE-2022-35914 Teclib GLPI Remote Code Execution
- CVE-2023-42802 GLPI vulnerable to unallowed PHP script execution
- CVE-2023-28849 GLPI vulnerable to SQL injection and Stored XSS via inventory agent request
- CVE-2022-35947 SQL injection in GLPI
- CVE-2022-31056 SQL injection with _actor parameter in GLPI
Sources
Also known as GHSA-55pm-mc2m-pq46, UBUNTU-CVE-2023-28636.