CVE-2023-28638 Stack references to locations outside buffers may become invalid if they exist during a GC compaction in Snappier

High 7.0 Published Updated

A race condition with garbage collection in Snappier can cause buffer overruns, leading to process termination and denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-28638?

CVE-2023-28638 is a high-severity memory corruption vulnerability in brantburnett Snappier, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Snappier is a high performance C# implementation of the Snappy compression algorithm. This is a buffer overrun vulnerability that can affect any user of Snappier 1.1.0. In this release, much of the code was rewritten to use byte references rather than pointers to pinned buffers. This change generally improves performance and reduces workload on the garbage collector. However, when the garbage collector performs compaction and rearranges memory, it must update any byte references on the stack to refer to the updated location. The .NET garbage collector can only update these byte references if they still point within the buffer or to a point one byte past the end of the buffer. If they point outside this area, the buffer itself may be moved while the byte reference stays the same. There are several places in 1.1.0 where byte references very briefly point outside the valid areas of buffers. These are at locations in the code being used for buffer range checks. While the invalid references are never dereferenced directly, if a GC compaction were to occur during the brief window when they are on the stack then it could invalidate the buffer range check and allow other operations to overrun the buffer. This should be very difficult for an attacker to trigger intentionally. It would require a repetitive bulk attack with the hope that a GC compaction would occur at precisely the right moment during one of the requests. However, one of the range checks with this problem is a check based on input data in the decompression buffer, meaning malformed input data could be used to increase the chance of success. Note that any resulting buffer overrun is likely to cause access to protected memory, which will then cause an exception and the process to be terminated. Therefore, the most likely result of an attack is a denial of service. This issue has been patched in release 1.1.1. Users are advised to upgrade. Users unable to upgrade may pin buffers to a fixed location before using them for compression or decompression to mitigate some, but not all, of these cases. At least one temporary decompression buffer is internal to the library and never pinned.

Weakness: CWE-119

Which versions are affected by CVE-2023-28638?

2 open source packages ship an affected version, including Snappier. It affects 1 product.

PackageAffectedFixed in
Snappier NuGetFrom 1.1.01.1.1
Snappier NuGetFrom 1.1.01.1.1

Products include Snappier Project Snappier.

How do I fix CVE-2023-28638?

Upgrade Snappier to 1.1.1 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2023-28638 being exploited?

There is no known exploitation of CVE-2023-28638 in the wild and no public exploit code.

Sources

Also known as GHSA-838x-pcvx-6p5w.

Is CVE-2023-28638 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free