# CVE-2023-28638: Stack references to locations outside buffers may become invalid if they exist during a GC compaction in Snappier

> A race condition with garbage collection in Snappier can cause buffer overruns, leading to process termination and denial of service.

- **Severity:** High 7.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2023
- **Updated:** 18 Feb 2025
- **Also known as:** GHSA-838x-pcvx-6p5w

## What is CVE-2023-28638?

CVE-2023-28638 is a high-severity memory corruption vulnerability in brantburnett Snappier, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Snappier is a high performance C# implementation of the Snappy compression algorithm. This is a buffer overrun vulnerability that can affect any user of Snappier 1.1.0. In this release, much of the code was rewritten to use byte references rather than pointers to pinned buffers. This change generally improves performance and reduces workload on the garbage collector. However, when the garbage collector performs compaction and rearranges memory, it must update any byte references on the stack to refer to the updated location. The .NET garbage collector can only update these byte references if they still point within the buffer or to a point one byte past the end of the buffer. If they point outside this area, the buffer itself may be moved while the byte reference stays the same. There are several places in 1.1.0 where byte references very briefly point outside the valid areas of buffers. These are at locations in the code being used for buffer range checks. While the invalid references are never dereferenced directly, if a GC compaction were to occur during the brief window when they are on the stack then it could invalidate the buffer range check and allow other operations to overrun the buffer.  This should be very difficult for an attacker to trigger intentionally. It would require a repetitive bulk attack with the hope that a GC compaction would occur at precisely the right moment during one of the requests. However, one of the range checks with this problem is a check based on input data in the decompression buffer, meaning malformed input data could be used to increase the chance of success. Note that any resulting buffer overrun is likely to cause access to protected memory, which will then cause an exception and the process to be terminated. Therefore, the most likely result of an attack is a denial of service. This issue has been patched in release 1.1.1. Users are advised to upgrade. Users unable to upgrade may pin buffers to a fixed location before using them for compression or decompression to mitigate some, but not all, of these cases. At least one temporary decompression buffer is internal to the library and never pinned.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2023-28638?

2 open source packages ship an affected version, including Snappier. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Snappier` | NuGet | From 1.1.0 | 1.1.1 |
| `Snappier` | NuGet | From 1.1.0 | 1.1.1 |

Products: Snappier Project Snappier.

## How do I fix CVE-2023-28638?

Upgrade Snappier to 1.1.1 or later.

## Is CVE-2023-28638 being exploited?

There is no known exploitation of CVE-2023-28638 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28638 and fix it if it is affected.

What it is: CVE-2023-28638 is a high-severity memory corruption vulnerability in brantburnett Snappier, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28638 in the wild and no public exploit code.

Affected packages and fixed versions:
- Snappier (NuGet): affected from 1.1.0; fixed in 1.1.1
- Snappier (NuGet): affected from 1.1.0; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28638/ (Markdown: https://insights.sbomify.com/CVE-2023-28638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28638
- OSV: https://osv.dev/vulnerability/CVE-2023-28638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28638/
Summaries are generated and may contain mistakes; the official description above is the record.
