CVE-2023-28639 GLPI vulnerable to reflected Cross-site Scripting in search pages
An attacker can craft a malicious link to execute scripts in the browser of an authenticated GLPI user, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2023-28639?
CVE-2023-28639 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 5 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
GLPI is a free asset and IT management software package. Starting in version 0.85 and prior to versions 9.5.13 and 10.0.7, a malicious link can be crafted by an unauthenticated user. It will be able to exploit a reflected XSS in case any authenticated user opens the crafted link. This issue is fixed in versions 9.5.13 and 10.0.7.
Weakness: CWE-79
Which versions are affected by CVE-2023-28639?
It affects 1 product.
Products include Glpi-Project Glpi.
How do I fix CVE-2023-28639?
No fix has been published for CVE-2023-28639 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-28639 being exploited?
There is no known exploitation of CVE-2023-28639 in the wild and no public exploit code.
Other vulnerabilities in Glpi-Project Glpi
- CVE-2022-35914 Teclib GLPI Remote Code Execution
- CVE-2023-42802 GLPI vulnerable to unallowed PHP script execution
- CVE-2023-28849 GLPI vulnerable to SQL injection and Stored XSS via inventory agent request
- CVE-2022-35947 SQL injection in GLPI
- CVE-2022-31056 SQL injection with _actor parameter in GLPI
Sources
Also known as GHSA-r93q-chh5-jgh4, UBUNTU-CVE-2023-28639.