# CVE-2023-28639: GLPI vulnerable to reflected Cross-site Scripting in search pages

> An attacker can craft a malicious link to execute scripts in the browser of an authenticated GLPI user, potentially leading to account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Apr 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-r93q-chh5-jgh4, UBUNTU-CVE-2023-28639

## What is CVE-2023-28639?

CVE-2023-28639 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 5 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

GLPI is a free asset and IT management software package. Starting in version 0.85 and prior to versions 9.5.13 and 10.0.7, a malicious link can be crafted by an unauthenticated user. It will be able to exploit a reflected XSS in case any authenticated user opens the crafted link. This issue is fixed in versions 9.5.13 and 10.0.7.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-28639?

It affects 1 product.


Products: Glpi-Project Glpi.

## How do I fix CVE-2023-28639?

No fix has been published for CVE-2023-28639 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-28639 being exploited?

There is no known exploitation of CVE-2023-28639 in the wild and no public exploit code.

## Other vulnerabilities in Glpi-Project Glpi

- [CVE-2022-35914](https://insights.sbomify.com/CVE-2022-35914/): Teclib GLPI Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2023-42802](https://insights.sbomify.com/CVE-2023-42802/): GLPI vulnerable to unallowed PHP script execution (critical 10.0)
- [CVE-2023-28849](https://insights.sbomify.com/CVE-2023-28849/): GLPI vulnerable to SQL injection and Stored XSS via inventory agent request (critical 10.0)
- [CVE-2022-35947](https://insights.sbomify.com/CVE-2022-35947/): SQL injection in GLPI (critical 10.0)
- [CVE-2022-31056](https://insights.sbomify.com/CVE-2022-31056/): SQL injection with _actor parameter in GLPI (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28639 and fix it if it is affected.

What it is: CVE-2023-28639 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 5 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-28639 in the wild and no public exploit code.

Affected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28639/ (Markdown: https://insights.sbomify.com/CVE-2023-28639/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28639
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28639
- OSV: https://osv.dev/vulnerability/CVE-2023-28639

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28639/
Summaries are generated and may contain mistakes; the official description above is the record.
