# CVE-2023-28640: Permissions bypass in Apiman could enable authenticated attacker to unpermitted API Key

> Authenticated attackers can access unauthorized API keys by guessing URLs, potentially allowing use of other users' resources without permission.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2023
- **Updated:** 19 Feb 2025
- **Also known as:** GHSA-m6f8-hjrv-mw5f

## What is CVE-2023-28640?

CVE-2023-28640 is a medium-severity missing authorization vulnerability in apiman, published on 27 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apiman is a flexible and open source API Management platform. Due to a missing permissions check, an attacker with an authenticated Apiman Manager account may be able to gain access to API keys they do not have permission for if they correctly guess the URL, which includes Organisation ID, Client ID, and Client Version of the targeted non-permitted resource. While not trivial to exploit, it could be achieved by brute-forcing or guessing common names. Access to the non-permitted API Keys could allow use of other users' resources without their permission (depending on the specifics of configuration, such as whether an API key is the only form of security). Apiman 3.1.0.Final resolved this issue. Users are advised to upgrade. The only known workaround is to restrict account access.

Weakness: CWE-862 (Missing Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-28640?

2 open source packages ship an affected version, including io.apiman:apiman-manager-api-rest-impl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.apiman:apiman-manager-api-rest-impl` | Maven | All versions | 3.1.0.Final |
| `io.apiman:apiman-manager-api-rest-impl` | Maven | All versions | 3.1.0.Final |

Products: Apiman Apiman.

## How do I fix CVE-2023-28640?

Upgrade io.apiman:apiman-manager-api-rest-impl to 3.1.0.Final or later.

## Is CVE-2023-28640 being exploited?

There is no known exploitation of CVE-2023-28640 in the wild and no public exploit code.

## Other vulnerabilities in apiman

- [CVE-2022-47551](https://insights.sbomify.com/CVE-2022-47551/): Apiman has potential permissions bypass (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28640 and fix it if it is affected.

What it is: CVE-2023-28640 is a medium-severity missing authorization vulnerability in apiman, published on 27 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28640 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.apiman:apiman-manager-api-rest-impl (Maven): affected all versions; fixed in 3.1.0.Final
- io.apiman:apiman-manager-api-rest-impl (Maven): affected all versions; fixed in 3.1.0.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28640/ (Markdown: https://insights.sbomify.com/CVE-2023-28640/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28640
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28640
- OSV: https://osv.dev/vulnerability/CVE-2023-28640

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28640/
Summaries are generated and may contain mistakes; the official description above is the record.
