# CVE-2023-28665: Cross-site scripting in Woo Bulk Price Update WordPress Plugin

> An authenticated attacker can execute arbitrary scripts via reflected XSS in the Woo Bulk Price Update plugin.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 22 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-2ggg-rwwg-7wg9

## What is CVE-2023-28665?

CVE-2023-28665 is a medium-severity cross-site scripting vulnerability in Woo Bulk Price Update WordPress Plugin, published on 22 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Woo Bulk Price Update WordPress plugin, in versions < 2.2.2, is affected by a reflected cross-site scripting vulnerability in the 'page' parameter to the techno_get_products action, which can only be triggered by an authenticated user.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-28665?

It affects 1 product.


Products: Technocrackers Bulk Price Update for Woocommerce.

## How do I fix CVE-2023-28665?

No fix has been published for CVE-2023-28665 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-28665 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28665 exists.

Public exploit code:

- Woo Bulk Price Update <2.2.2 - Cross-Site Scripting (nuclei): http/cves/2023/CVE-2023-28665.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28665 and fix it if it is affected.

What it is: CVE-2023-28665 is a medium-severity cross-site scripting vulnerability in Woo Bulk Price Update WordPress Plugin, published on 22 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28665 exists.

Affected product: Woo Bulk Price Update WordPress Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28665/ (Markdown: https://insights.sbomify.com/CVE-2023-28665/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28665
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28665
- OSV: https://osv.dev/vulnerability/CVE-2023-28665

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28665/
Summaries are generated and may contain mistakes; the official description above is the record.
