{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:jacoco. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28669 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:jacoco to 3.3.2.1 or later.","what":"CVE-2023-28669 is a medium-severity cross-site scripting vulnerability in Jenkins JaCoCo Plugin, published on 23 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-28669 and fix it if it is affected.\n\nWhat it is: CVE-2023-28669 is a medium-severity cross-site scripting vulnerability in Jenkins JaCoCo Plugin, published on 23 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-28669 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:jacoco (Maven): affected all versions; fixed in 3.3.2.1\n- org.jenkins-ci.plugins:jacoco (Maven): affected all versions; fixed in 3.3.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28669/ (Markdown: https://insights.sbomify.com/CVE-2023-28669/index.md)","id":"CVE-2023-28669","markdown":"https://insights.sbomify.com/CVE-2023-28669/index.md","name":"CVE-2023-28669","record":{"aliases":["GHSA-xj29-gfww-j67g"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins JaCoCo Plugin","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts into Jenkins UI via coverage report inputs, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"jacoco","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins JaCoCo Plugin 3.3.2 and earlier does not escape class and method names shown on the UI, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control input files for the 'Record JaCoCo coverage report' post-build action.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins JaCoCo Plugin vulnerable to Stored Cross-site Scripting","id":"CVE-2023-28669","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Pipeline Aggregator View Plugin vulnerable to Cross-site Scripting","id":"CVE-2023-28670"},"packages":[{"ecosystem":"Maven","fixed":["3.3.2.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:jacoco","purl":null,"source":"GHSA-xj29-gfww-j67g"},{"ecosystem":"Maven","fixed":["3.3.2.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:jacoco","purl":"pkg:maven/org.jenkins-ci.plugins/jacoco","source":"GHSA-xj29-gfww-j67g"}],"prev":{"headline":"Jenkins Role-based Authorization Strategy Plugin grants permissions even after they’ve been disabled","id":"CVE-2023-28668"},"products":["Jenkins JaCoCo Plugin"],"published":"2023-03-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["Jenkins Project"]},"summary":"Attackers can inject malicious scripts into Jenkins UI via coverage report inputs, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2023-28669/"}