# CVE-2023-28669: Jenkins JaCoCo Plugin vulnerable to Stored Cross-site Scripting

> Attackers can inject malicious scripts into Jenkins UI via coverage report inputs, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-xj29-gfww-j67g

## What is CVE-2023-28669?

CVE-2023-28669 is a medium-severity cross-site scripting vulnerability in Jenkins JaCoCo Plugin, published on 23 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins JaCoCo Plugin 3.3.2 and earlier does not escape class and method names shown on the UI, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control input files for the 'Record JaCoCo coverage report' post-build action.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-28669?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:jacoco. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:jacoco` | Maven | All versions | 3.3.2.1 |
| `org.jenkins-ci.plugins:jacoco` | Maven | All versions | 3.3.2.1 |

Products: Jenkins Jacoco.

## How do I fix CVE-2023-28669?

Upgrade org.jenkins-ci.plugins:jacoco to 3.3.2.1 or later.

## Is CVE-2023-28669 being exploited?

There is no known exploitation of CVE-2023-28669 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28669 and fix it if it is affected.

What it is: CVE-2023-28669 is a medium-severity cross-site scripting vulnerability in Jenkins JaCoCo Plugin, published on 23 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-28669 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:jacoco (Maven): affected all versions; fixed in 3.3.2.1
- org.jenkins-ci.plugins:jacoco (Maven): affected all versions; fixed in 3.3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28669/ (Markdown: https://insights.sbomify.com/CVE-2023-28669/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28669
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28669
- OSV: https://osv.dev/vulnerability/CVE-2023-28669

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28669/
Summaries are generated and may contain mistakes; the official description above is the record.
