{"answers":{"affected":"2 open source packages ship an affected version, including com.paul8620.jenkins.plugins:pipeline-aggregator-view. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28670 in the wild and no public exploit code.","fix":"Upgrade com.paul8620.jenkins.plugins:pipeline-aggregator-view to 1.14 or later.","what":"CVE-2023-28670 is a medium-severity cross-site scripting vulnerability in Jenkins Pipeline Aggregator View Plugin, published on 23 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-28670 and fix it if it is affected.\n\nWhat it is: CVE-2023-28670 is a medium-severity cross-site scripting vulnerability in Jenkins Pipeline Aggregator View Plugin, published on 23 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-28670 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.paul8620.jenkins.plugins:pipeline-aggregator-view (Maven): affected all versions; fixed in 1.14\n- com.paul8620.jenkins.plugins:pipeline-aggregator-view (Maven): affected all versions; fixed in 1.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28670/ (Markdown: https://insights.sbomify.com/CVE-2023-28670/index.md)","id":"CVE-2023-28670","markdown":"https://insights.sbomify.com/CVE-2023-28670/index.md","name":"CVE-2023-28670","record":{"aliases":["GHSA-v27q-87jf-j9cr"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Authenticated attackers can inject malicious scripts into Jenkins views via unescaped URLs, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"pipeline_aggregator_view","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Pipeline Aggregator View Plugin 1.13 and earlier does not escape a variable representing the current view's URL in inline JavaScript, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by authenticated attackers with Overall/Read permission.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Pipeline Aggregator View Plugin vulnerable to Cross-site Scripting","id":"CVE-2023-28670","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins OctoPerf Load Testing Plugin vulnerable to Cross-site Request Forgery","id":"CVE-2023-28671"},"packages":[{"ecosystem":"Maven","fixed":["1.14"],"introduced":["0"],"last_affected":[],"package":"com.paul8620.jenkins.plugins:pipeline-aggregator-view","purl":null,"source":"GHSA-v27q-87jf-j9cr"},{"ecosystem":"Maven","fixed":["1.14"],"introduced":["0"],"last_affected":[],"package":"com.paul8620.jenkins.plugins:pipeline-aggregator-view","purl":"pkg:maven/com.paul8620.jenkins.plugins/pipeline-aggregator-view","source":"GHSA-v27q-87jf-j9cr"}],"prev":{"headline":"Jenkins JaCoCo Plugin vulnerable to Stored Cross-site Scripting","id":"CVE-2023-28669"},"products":["Jenkins Pipeline Aggregator View Plugin"],"published":"2023-03-23","related":[{"cvss_score":5.4,"headline":"Jenkins Pipeline Aggregator View Plugin stored XSS vulnerability","id":"CVE-2019-16564","kev_date_added":null,"published":"2019-12-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["Jenkins Project"]},"summary":"Authenticated attackers can inject malicious scripts into Jenkins views via unescaped URLs, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2023-28670/"}