{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkinsci.plugins:octoperf. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28671 in the wild and no public exploit code.","fix":"Upgrade org.jenkinsci.plugins:octoperf to 4.5.1 or later.","what":"CVE-2023-28671 is a medium-severity vulnerability in Jenkins OctoPerf Load Testing Plugin Plugin, published on 23 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-28671 and fix it if it is affected.\n\nWhat it is: CVE-2023-28671 is a medium-severity vulnerability in Jenkins OctoPerf Load Testing Plugin Plugin, published on 23 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-28671 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkinsci.plugins:octoperf (Maven): affected all versions; fixed in 4.5.1\n- org.jenkinsci.plugins:octoperf (Maven): affected all versions; fixed in 4.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28671/ (Markdown: https://insights.sbomify.com/CVE-2023-28671/index.md)","id":"CVE-2023-28671","markdown":"https://insights.sbomify.com/CVE-2023-28671/index.md","name":"CVE-2023-28671","record":{"aliases":["GHSA-wq3w-3rxh-vcxx"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"none","summary":"Attackers can exploit CSRF to connect to malicious URLs using stolen credentials, capturing sensitive data stored in Jenkins.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"octoperf_load_testing","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery (CSRF) vulnerability in Jenkins OctoPerf Load Testing Plugin Plugin 4.5.0 and earlier allows attackers to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins OctoPerf Load Testing Plugin vulnerable to Cross-site Request Forgery","id":"CVE-2023-28671","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins OctoPerf Load Testing Plugin vulnerable to credential capture","id":"CVE-2023-28672"},"packages":[{"ecosystem":"Maven","fixed":["4.5.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkinsci.plugins:octoperf","purl":null,"source":"GHSA-wq3w-3rxh-vcxx"},{"ecosystem":"Maven","fixed":["4.5.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkinsci.plugins:octoperf","purl":"pkg:maven/org.jenkinsci.plugins/octoperf","source":"GHSA-wq3w-3rxh-vcxx"}],"prev":{"headline":"Jenkins Pipeline Aggregator View Plugin vulnerable to Cross-site Scripting","id":"CVE-2023-28670"},"products":["Jenkins OctoPerf Load Testing Plugin Plugin"],"published":"2023-03-23","related":[{"cvss_score":8.8,"headline":"Jenkins OctoPerf Load Testing Plugin vulnerable to Cross-site Request Forgery","id":"CVE-2023-28674","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":6.5,"headline":"Jenkins OctoPerf Load Testing Plugin vulnerable to credential capture","id":"CVE-2023-28672","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":4.3,"headline":"Jenkins OctoPerf Load Testing Plugin missing permission check allows for ID enumeration","id":"CVE-2023-28673","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":4.3,"headline":"Jenkins OctoPerf Load Testing Plugin missing permission check allows for unauthorized server connections","id":"CVE-2023-28675","kev_date_added":null,"published":"2023-03-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["Jenkins Project"]},"summary":"Attackers can exploit CSRF to connect to malicious URLs using stolen credentials, capturing sensitive data stored in Jenkins.","url":"https://insights.sbomify.com/CVE-2023-28671/"}