# CVE-2023-28674: Jenkins OctoPerf Load Testing Plugin vulnerable to Cross-site Request Forgery

> Attackers can force users to connect to an OctoPerf server with attacker-controlled credentials via CSRF in the Jenkins plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-x263-hp5c-p2rj

## What is CVE-2023-28674?

CVE-2023-28674 is a high-severity vulnerability in Jenkins OctoPerf Load Testing Plugin Plugin, published on 23 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins OctoPerf Load Testing Plugin Plugin 4.5.2 and earlier allows attackers to connect to a previously configured Octoperf server using attacker-specified credentials.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-28674?

2 open source packages ship an affected version, including org.jenkinsci.plugins:octoperf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkinsci.plugins:octoperf` | Maven | All versions | 4.5.3 |
| `org.jenkinsci.plugins:octoperf` | Maven | All versions | 4.5.3 |

Products: Jenkins Octoperf Load Testing.

## How do I fix CVE-2023-28674?

Upgrade org.jenkinsci.plugins:octoperf to 4.5.3 or later.

## Is CVE-2023-28674 being exploited?

There is no known exploitation of CVE-2023-28674 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins OctoPerf Load Testing Plugin Plugin

- [CVE-2023-28672](https://insights.sbomify.com/CVE-2023-28672/): Jenkins OctoPerf Load Testing Plugin vulnerable to credential capture (medium 6.5)
- [CVE-2023-28671](https://insights.sbomify.com/CVE-2023-28671/): Jenkins OctoPerf Load Testing Plugin vulnerable to Cross-site Request Forgery (medium 4.3)
- [CVE-2023-28673](https://insights.sbomify.com/CVE-2023-28673/): Jenkins OctoPerf Load Testing Plugin missing permission check allows for ID enumeration (medium 4.3)
- [CVE-2023-28675](https://insights.sbomify.com/CVE-2023-28675/): Jenkins OctoPerf Load Testing Plugin missing permission check allows for unauthorized server connections (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28674 and fix it if it is affected.

What it is: CVE-2023-28674 is a high-severity vulnerability in Jenkins OctoPerf Load Testing Plugin Plugin, published on 23 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-28674 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkinsci.plugins:octoperf (Maven): affected all versions; fixed in 4.5.3
- org.jenkinsci.plugins:octoperf (Maven): affected all versions; fixed in 4.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28674/ (Markdown: https://insights.sbomify.com/CVE-2023-28674/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28674
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28674
- OSV: https://osv.dev/vulnerability/CVE-2023-28674

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28674/
Summaries are generated and may contain mistakes; the official description above is the record.
